dev-haskell/shellish: tweak for ghc-8
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 6 Nov 2016 11:39:52 +0000 (11:39 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 6 Nov 2016 12:02:57 +0000 (12:02 +0000)
Package-Manager: portage-2.3.2

dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch [new file with mode: 0644]
dev-haskell/shellish/shellish-0.1.4.ebuild

diff --git a/dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch b/dev-haskell/shellish/files/shellish-0.1.4-ghc-8.patch
new file mode 100644 (file)
index 0000000..4952554
--- /dev/null
@@ -0,0 +1,9 @@
+diff --git a/Shellish.hs b/Shellish.hs
+index 0ac20c2..7de0e11 100644
+--- a/Shellish.hs
++++ b/Shellish.hs
+@@ -180,3 +180,3 @@ test_s = path >=> liftIO . \f -> do
+   stat <- getSymbolicLinkStatus f
+-  return $ isSymbolicLink stat
++  return $ System.PosixCompat.Files.isSymbolicLink stat
index f93d8797cc7ac228f03d79cfee850fbcec355a2c..55236c96777eaa8dacf658a3743c63bf6c930833 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -27,4 +27,5 @@ DEPEND="${RDEPEND}
 
 src_prepare() {
        epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+       epatch "${FILESDIR}"/${P}-ghc-8.patch
 }