app-emulation/simplevirt: use acct-group, remove longdescription
authorRafael Martins <rafaelmartins@gentoo.org>
Wed, 6 May 2020 20:41:29 +0000 (22:41 +0200)
committerRafael Martins <rafaelmartins@gentoo.org>
Wed, 6 May 2020 20:42:38 +0000 (22:42 +0200)
Closes: https://bugs.gentoo.org/694812
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Rafael Martins <rafaelmartins@gentoo.org>
app-emulation/simplevirt/metadata.xml
app-emulation/simplevirt/simplevirt-0.0_p20181012-r1.ebuild [moved from app-emulation/simplevirt/simplevirt-0.0_p20181012.ebuild with 93% similarity]

index 25e89f9e595900d2c92bd96c56015948ada40d6a..e45e3daf442e9fb161e8cd69fa78bb037c8c91ce 100644 (file)
@@ -5,9 +5,6 @@
                <email>rafaelmartins@gentoo.org</email>
                <name>Rafael G. Martins</name>
        </maintainer>
-       <longdescription lang="en">
-               Simple virtual machine manager for Linux (QEMU/KVM)
-       </longdescription>
        <upstream>
                <maintainer status="active">
                        <email>rafael@rafaelmartins.eng.br</email>
similarity index 93%
rename from app-emulation/simplevirt/simplevirt-0.0_p20181012.ebuild
rename to app-emulation/simplevirt/simplevirt-0.0_p20181012-r1.ebuild
index 8f7c69b4bddc241f7ab4392cd0a1900c40a5366b..45f5a524d281c462a1bea255cb111f0096efe7c1 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -11,7 +11,7 @@ EGO_VENDOR=(
        "gopkg.in/yaml.v2 v2.2.1 github.com/go-yaml/yaml"
 )
 
-inherit linux-info golang-vcs-snapshot user
+inherit linux-info golang-vcs-snapshot
 
 EGO_PN="github.com/rafaelmartins/simplevirt"
 GIT_COMMIT="78d29d8fa11ce72af5f897430af7bb7d2947a32f"
@@ -30,6 +30,7 @@ KEYWORDS=""
 IUSE=""
 
 RDEPEND="
+       acct-group/simplevirt
        virtual/logger
        app-emulation/qemu"
 
@@ -37,12 +38,6 @@ CONFIG_CHECK="~TUN ~BRIDGE"
 ERROR_TUN="CONFIG_TUN: Universal TUN/TAP driver required to setup bridge networking"
 ERROR_BRIDGE="CONFIG_BRIDGE: 802.1d Ethernet Bridging required to setup bridge networking"
 
-pkg_setup() {
-       enewgroup simplevirt
-
-       linux-info_pkg_setup
-}
-
 src_compile() {
        pushd src/${EGO_PN} > /dev/null || die
        GOPATH="${S}" go install -v -ldflags "-X ${EGO_PN}.Version=${GIT_VERSION}" ./cmd/... || die