app-accessibility/speech-dispatcher: disable static libraries
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>
Mon, 7 Oct 2019 15:37:39 +0000 (17:37 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 20 Oct 2019 11:47:55 +0000 (13:47 +0200)
Closes: https://bugs.gentoo.org/696890
Closes: https://github.com/gentoo/gentoo/pull/13199
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Signed-off-by: David Seifert <soap@gentoo.org>
app-accessibility/speech-dispatcher/speech-dispatcher-0.8.7-r2.ebuild [moved from app-accessibility/speech-dispatcher/speech-dispatcher-0.8.7.ebuild with 96% similarity]
app-accessibility/speech-dispatcher/speech-dispatcher-0.8.7-r3.ebuild [moved from app-accessibility/speech-dispatcher/speech-dispatcher-0.8.7-r1.ebuild with 95% similarity]

similarity index 96%
rename from app-accessibility/speech-dispatcher/speech-dispatcher-0.8.7.ebuild
rename to app-accessibility/speech-dispatcher/speech-dispatcher-0.8.7-r2.ebuild
index 09dbe1a312e6842e937c091626f2692a61cd96cc..bb3f73c4ceeeb397cb0c5af43b42fbd6b8541b1a 100644 (file)
@@ -14,7 +14,7 @@ SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="alpha amd64 arm arm64 ~hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="alsa ao +espeak flite nas pulseaudio python static-libs"
+IUSE="alsa ao +espeak flite nas pulseaudio python"
 
 REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
 
@@ -41,7 +41,7 @@ src_configure() {
 
        local myeconfargs=(
                --disable-python
-               $(use_enable static-libs static)
+               --disable-static
                $(use_with alsa)
                $(use_with ao libao)
                $(use_with espeak)
similarity index 95%
rename from app-accessibility/speech-dispatcher/speech-dispatcher-0.8.7-r1.ebuild
rename to app-accessibility/speech-dispatcher/speech-dispatcher-0.8.7-r3.ebuild
index 44d74058468a80c37ca14bed6dd9b9fbf27835dc..62fb7fc04843ec120acf38a570a8f66ec2fd3935 100644 (file)
@@ -14,7 +14,7 @@ SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="alsa ao +espeak flite nas pulseaudio python static-libs"
+IUSE="alsa ao +espeak flite nas pulseaudio python"
 
 REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
 
@@ -41,7 +41,7 @@ src_configure() {
 
        local myeconfargs=(
                --disable-python
-               $(use_enable static-libs static)
+               --disable-static
                $(use_with alsa)
                $(use_with ao libao)
                $(use_with espeak)
@@ -72,8 +72,6 @@ src_install() {
        emake DESTDIR="${D}" install
        dodoc ANNOUNCE AUTHORS BUGS FAQ NEWS README*
 
-       prune_libtool_files --all
-
        if use python; then
                installation() {
                        cd src/api/python || die
@@ -86,6 +84,8 @@ src_install() {
                python_foreach_impl run_in_build_dir installation
                python_replicate_script "${ED}"/usr/bin/spd-conf
        fi
+
+       find "${D}" -name '*.la' -delete || die
 }
 
 pkg_postinst() {