dev-python/audioread: Drop 2.1.8 (r0)
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Dec 2019 18:26:58 +0000 (19:26 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 8 Dec 2019 18:27:40 +0000 (19:27 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-python/audioread/audioread-2.1.8.ebuild [deleted file]

diff --git a/dev-python/audioread/audioread-2.1.8.ebuild b/dev-python/audioread/audioread-2.1.8.ebuild
deleted file mode 100644 (file)
index 885840e..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1
-
-DESCRIPTION="Wrapper for audio file decoding using FFmpeg or GStreamer"
-HOMEPAGE="https://pypi.org/project/audioread/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-BDEPEND="
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-RDEPEND="
-       || (
-               (
-                       dev-python/pygobject:3[${PYTHON_USEDEP}]
-                       media-libs/gstreamer:1.0
-                       media-plugins/gst-plugins-meta:1.0
-               )
-               virtual/ffmpeg
-       )
-"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=( "${FILESDIR}/${P}-test-deps.patch" ) # git master
-
-python_prepare_all() {
-       distutils-r1_python_prepare_all
-       sed -e "/'pytest-runner'/d" -i setup.py || die
-}
-
-pkg_postinst() {
-       einfo "You may need to emerge additional GStreamer plugins or enable"
-       einfo "additional USE flags in media-video/ffmpeg to decode some types"
-       einfo "of audio files."
-}