dev-ros/filters: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 19:18:12 +0000 (21:18 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 19:22:08 +0000 (21:22 +0200)
Package-Manager: portage-2.2.21

dev-ros/filters/Manifest [new file with mode: 0644]
dev-ros/filters/files/tests.patch [new file with mode: 0644]
dev-ros/filters/filters-1.7.4.ebuild [new file with mode: 0644]
dev-ros/filters/filters-9999.ebuild [new file with mode: 0644]
dev-ros/filters/metadata.xml [new file with mode: 0644]

diff --git a/dev-ros/filters/Manifest b/dev-ros/filters/Manifest
new file mode 100644 (file)
index 0000000..a63337f
--- /dev/null
@@ -0,0 +1 @@
+DIST filters-1.7.4.tar.gz 16979 SHA256 fb71f1fbeaf89726877fce66dce1db8957c5cc6dffa1973d6a104a10233f8237 SHA512 74a0b64b7225f0b28e369f58fe9e5d639ed80acd18db849b1519e725b7566e6299b01e07559105c3072a781ba56b54d6a5887b02145700e046aeeb2740cbcc80 WHIRLPOOL 336f915d81b52f5b56d55026478ed60d3aa4a67cf281368213b446046edaf8b092f006818dbd54a7f7dc87b5575eda565d5ab8845b1c2f5e5be6d13ea24b3876
diff --git a/dev-ros/filters/files/tests.patch b/dev-ros/filters/files/tests.patch
new file mode 100644 (file)
index 0000000..ee1f862
--- /dev/null
@@ -0,0 +1,23 @@
+Upstream status: Merged.
+https://github.com/ros/filters/commit/2607c82034cdfbf96fe372c9637b0133b6ba6970
+
+Index: filters-1.7.4/CMakeLists.txt
+===================================================================
+--- filters-1.7.4.orig/CMakeLists.txt
++++ filters-1.7.4/CMakeLists.txt
+@@ -40,6 +40,7 @@ target_link_libraries(median ${catkin_LI
+ add_library(transfer_function src/transfer_function.cpp)
+ target_link_libraries(transfer_function ${catkin_LIBRARIES} ${Boost_LIBRARIES})
++if(CATKIN_ENABLE_TESTING)
+ # Test median filter
+ add_executable(median_test EXCLUDE_FROM_ALL test/test_median.cpp )
+ target_link_libraries(median_test median ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES}) 
+@@ -67,6 +68,7 @@ add_rostest(test/test_chain.launch)
+ # Test realtime safe buffer class
+ catkin_add_gtest(realtime_buffer_test EXCLUDE_FROM_ALL test/test_realtime_circular_buffer.cpp)
++endif()
+ ##############################################################################
+ # Install
diff --git a/dev-ros/filters/filters-1.7.4.ebuild b/dev-ros/filters/filters-1.7.4.ebuild
new file mode 100644 (file)
index 0000000..4b50ee0
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/filters"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Standardized interface for processing data as a sequence of filters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/roscpp
+       dev-ros/pluginlib"
+DEPEND="${RDEPEND}
+       test? ( dev-ros/rostest dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/tests.patch" )
diff --git a/dev-ros/filters/filters-9999.ebuild b/dev-ros/filters/filters-9999.ebuild
new file mode 100644 (file)
index 0000000..4b50ee0
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/filters"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Standardized interface for processing data as a sequence of filters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/roscpp
+       dev-ros/pluginlib"
+DEPEND="${RDEPEND}
+       test? ( dev-ros/rostest dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/tests.patch" )
diff --git a/dev-ros/filters/metadata.xml b/dev-ros/filters/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>