app-emacs/desktop+: Inline autoloads.
authorUlrich Müller <ulm@gentoo.org>
Thu, 17 Oct 2019 12:50:23 +0000 (14:50 +0200)
committerUlrich Müller <ulm@gentoo.org>
Thu, 17 Oct 2019 13:19:04 +0000 (15:19 +0200)
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/desktop+/desktop+-0.2-r1.ebuild [moved from app-emacs/desktop+/desktop+-0.2.ebuild with 68% similarity]
app-emacs/desktop+/files/50desktop+-gentoo.el

similarity index 68%
rename from app-emacs/desktop+/desktop+-0.2.ebuild
rename to app-emacs/desktop+/desktop+-0.2-r1.ebuild
index adf858b1a86d531ac358c61d63617a2ecf854d7e..b4016a3364f9a6669ab8f7bf0fd35b968a73315a 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit elisp
 
@@ -11,17 +11,13 @@ SRC_URI="https://github.com/ffevotte/desktop-plus/archive/v${PV}.tar.gz -> ${P}.
 
 LICENSE="GPL-3+"
 SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
 RESTRICT="test"
 
-RDEPEND="app-emacs/dash app-emacs/f"
-DEPEND="${RDEPEND}"
+RDEPEND="app-emacs/dash
+       app-emacs/f"
+BDEPEND="${RDEPEND}"
 
 S="${WORKDIR}/desktop-plus-${PV}"
 SITEFILE="50${PN}-gentoo.el"
 DOCS="README.md"
-
-src_compile() {
-       elisp-compile *.el
-       elisp-make-autoload-file
-}
index ca3b3828a3ed44cb98e37d3d456106540fe3a436..6ccccf547c066e9155d855dbc1f9bef3291d07df 100644 (file)
@@ -1,2 +1,9 @@
 (add-to-list 'load-path "@SITELISP@")
-(load "desktop+-autoloads" nil t)
+(autoload 'desktop+-create "desktop+"
+  "Create a new session, identified by a name." t)
+(autoload 'desktop+-load "desktop+"
+  "Load a session previously created using `desktop+-create'." t)
+(autoload 'desktop+-create-auto "desktop+"
+  "Create a new session, identified by the current working directory." t)
+(autoload 'desktop+-load-auto "desktop+"
+  "Load a session previously created using `desktop+-create-auto'. t)