dev-python/sphinxcontrib-qthelp: Bump to 1.0.3, add tests
authorMichał Górny <mgorny@gentoo.org>
Mon, 2 Mar 2020 14:57:01 +0000 (15:57 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 2 Mar 2020 15:16:38 +0000 (16:16 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinxcontrib-qthelp/Manifest
dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.ebuild [new file with mode: 0644]

index ddc066c54d7b3ca482f2d77c6628d0593f0063be..3ca64686ff462aac7d612116b5c990cc0a1fda76 100644 (file)
@@ -1 +1,2 @@
 DIST sphinxcontrib-qthelp-1.0.2.tar.gz 17804 BLAKE2B f3d6a67469c82e2a6e90b75d506ee3faa896d8ec408d60f93f74c8cc4bafb22772f85e36c286a96cecf2d7808338da233910055404969ef311f935173f06f376 SHA512 8fe840e011fabd596194f539d27a502b77ae8a6030ae1a7646b1af9f203d3578b7420ead655297b2a752f0cb0e6803247c7a79b2ccd2d4662ed9f58398947864
+DIST sphinxcontrib-qthelp-1.0.3.tar.gz 21658 BLAKE2B 7a82e8941d49836cf3e64aabe05ba65b34596f7ba0287b4dc7ed2c5940f6944d1853790d1d52637b03d934effbba8fc5094089e2924322cf1b373432c60bce6a SHA512 29f77e4b3f1a4868c2a34dbd853415e5d813f482cd23b982aeed42d53acba09b896d77ba930c34cce8af043bb7d64a19acff610430e942038d95a410b6e0b5fa
diff --git a/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.ebuild b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.ebuild
new file mode 100644 (file)
index 0000000..5474377
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs QtHelp documents"
+HOMEPAGE="https://www.sphinx-doc.org
+       https://github.com/sphinx-doc/sphinxcontrib-qthelp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND="dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+PDEPEND="
+       >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( ${PDEPEND} )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+       distutils-r1_python_install_all
+       find "${ED}" -name '*.pth' -delete || die
+}