sys-kernel/ck-sources: experimental USE handling / 4.13 EOL
authorkuzetsa <kuzetsa@gmail.com>
Tue, 5 Dec 2017 18:28:22 +0000 (13:28 -0500)
committerMichael Palimaka <kensington@gentoo.org>
Wed, 6 Dec 2017 12:31:58 +0000 (23:31 +1100)
user-facing einfo message for genpatches-related USE
update metadata.xml (with URL) for experimental USE
removal of legacy K_EXP_* (workaround) behavior
converted to IUSE experimental (via kernel-2.eclass)

user-facing ewarn message advising users of EOL

Closes: https://github.com/gentoo/gentoo/pull/6428
Package-Manager: Portage-2.3.13, Repoman-2.3.3

sys-kernel/ck-sources/ck-sources-4.13.16-r1.ebuild [new file with mode: 0644]
sys-kernel/ck-sources/metadata.xml

diff --git a/sys-kernel/ck-sources/ck-sources-4.13.16-r1.ebuild b/sys-kernel/ck-sources/ck-sources-4.13.16-r1.ebuild
new file mode 100644 (file)
index 0000000..a754ac4
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+KEYWORDS="~amd64 ~x86"
+
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches/
+       http://kernel.kolivas.org/"
+
+IUSE="experimental"
+
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="19"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1 kernel-2
+detect_version
+detect_arch
+
+DEPEND="deblob? ( ${PYTHON_DEPS} )"
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+
+DESCRIPTION="Con Kolivas' high performance patchset and Gentoo's genpatches for Linux ${K_BRANCH_ID}"
+
+CK_VERSION="1"
+
+CK_FILE="patch-${K_BRANCH_ID}-ck${CK_VERSION}.xz"
+
+CK_BASE_URL="http://ck.kolivas.org/patches/4.0"
+CK_LVER_URL="${CK_BASE_URL}/${K_BRANCH_ID}/${K_BRANCH_ID}-ck${CK_VERSION}"
+CK_URI="${CK_LVER_URL}/${CK_FILE}"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/${CK_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_setup() {
+       use deblob && python-any-r1_pkg_setup
+       kernel-2_pkg_setup
+}
+
+src_prepare() {
+
+#-- Comment out CK's EXTRAVERSION in Makefile ---------------------------------
+
+       # linux-info eclass cannot handle recursively expanded variables in Makefile #490328
+       sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile" || die
+
+       kernel-2_src_prepare
+}
+
+pkg_postinst() {
+       elog "ck-sources previously enabled CPU optimizations by default."
+       elog "USE=\"experimental\" is now required to enable this patch."
+       elog "this can be set in /etc/portage/package.use (or make.conf)"
+
+       ewarn "kernel.org marked 4.13 branch EOL (end of life)"
+       ewarn "upgrading to a newer release is recommended."
+}
index 92ef277f18eb4bbcc27f78c2e923ce0f8d7b976c..4eadcd1d08a441f3d04af002d7558c00624478e0 100644 (file)
@@ -17,6 +17,7 @@
     <flag name="deblob">Remove binary blobs from kernel sources to provide
       libre license compliance.
     </flag>
+    <flag name="experimental">Apply experimental patches; for more information, see "https://wiki.gentoo.org/wiki/Project:Kernel/Experimental".</flag>
   </use>
   <upstream>
     <remote-id type="cpe">cpe:/o:linux:linux_kernel</remote-id>