games-arcade/opentyrian: add gnome2-utils
authorMarty E. Plummer <hanetzer@startmail.com>
Fri, 3 Aug 2018 01:22:12 +0000 (20:22 -0500)
committerJames Le Cuirot <chewi@gentoo.org>
Mon, 27 Aug 2018 21:23:02 +0000 (22:23 +0100)
Needed for gnome2_icon_cache_update in pkg_postinst and pkg_postrm.

Package-Manager: Portage-2.3.44, Repoman-2.3.10

games-arcade/opentyrian/opentyrian-2.1.20130907-r1.ebuild

index f1b0678fb4ea7ab2eceaee7d0c025874315d351e..fc82628bc5218e56349e3db65c51ff7b0f8d40e7 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-inherit desktop
+inherit desktop gnome2-utils
 
 DESCRIPTION="Open-source port of the DOS game Tyrian, vertical scrolling shooter"
 HOMEPAGE="https://bitbucket.org/opentyrian/opentyrian/wiki/Home"
@@ -47,3 +47,11 @@ src_install() {
        rm *.exe dpmi16bi.ovl loudness.awe || die "Failed to remove win32 binaries"
        doins * || die "Failed to install game data"
 }
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}