dev-ml/fmt: Initial import; ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Thu, 23 Feb 2017 07:25:45 +0000 (08:25 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 23 Feb 2017 09:15:48 +0000 (10:15 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ml/fmt/Manifest [new file with mode: 0644]
dev-ml/fmt/fmt-0.8.0.ebuild [new file with mode: 0644]
dev-ml/fmt/metadata.xml [new file with mode: 0644]

diff --git a/dev-ml/fmt/Manifest b/dev-ml/fmt/Manifest
new file mode 100644 (file)
index 0000000..0343c82
--- /dev/null
@@ -0,0 +1 @@
+DIST fmt-0.8.0.tbz 14965 SHA256 fd221052a9d2c9be0a8f32d14b2cb35d72ec6f7cd828244759392adbec8ac79b SHA512 5287ff80343ab7f2b33e87b48ff4301e1152b54da1f1de6d8ac235f909cd83e8c9219fd46dbbe239aa6736b406c884141b3ab7578d6a3b2ff289d7756a09ec44 WHIRLPOOL 06eac9e3c3f97f196d2727bd07bf06ccbe4761b77c51fa25bab90575b40db612caf58f4b7685905f67a0ad36c82aa241c2db215c85e574930d1c19e2a6ee5176
diff --git a/dev-ml/fmt/fmt-0.8.0.ebuild b/dev-ml/fmt/fmt-0.8.0.ebuild
new file mode 100644 (file)
index 0000000..71ca3f3
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Combinators to devise OCaml Format pretty-printing functions"
+HOMEPAGE="http://erratique.ch/software/fmt https://github.com/dbuenzli/fmt"
+SRC_URI="http://erratique.ch/software/fmt/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-ml/result:=[ocamlopt]
+       dev-lang/ocaml:=[ocamlopt]
+       dev-ml/cmdliner:=[ocamlopt]"
+DEPEND="${RDEPEND}
+       dev-ml/opam
+       dev-ml/topkg
+       dev-ml/ocamlbuild
+       dev-ml/findlib"
+
+src_compile() {
+       ocaml pkg/pkg.ml build || die
+}
+
+src_test() {
+       ocamlbuild -use-ocamlfind test/tests.otarget || die
+       ./test.native || die
+       ./test.byte   || die
+}
+
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+       dodoc CHANGES.md README.md
+}
diff --git a/dev-ml/fmt/metadata.xml b/dev-ml/fmt/metadata.xml
new file mode 100644 (file)
index 0000000..ffac4d7
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>ml@gentoo.org</email>
+       <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>