ros-meta/robot: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 19:29:52 +0000 (21:29 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 19:30:02 +0000 (21:30 +0200)
Package-Manager: portage-2.2.21

ros-meta/robot/Manifest [new file with mode: 0644]
ros-meta/robot/metadata.xml [new file with mode: 0644]
ros-meta/robot/robot-1.2.0.ebuild [new file with mode: 0644]
ros-meta/robot/robot-9999.ebuild [new file with mode: 0644]

diff --git a/ros-meta/robot/Manifest b/ros-meta/robot/Manifest
new file mode 100644 (file)
index 0000000..7ebda7a
--- /dev/null
@@ -0,0 +1 @@
+DIST metapackages-1.2.0.tar.gz 1803 SHA256 02360aefee1a3ec8506cb475be00a053827d422fed26d123764b4d6b18b0a5c5 SHA512 a004a1323c93e191b98a4fe665409fb57396fb06c19e9205817f2467e171bfba10a86713978e13739632e04f148b476e582c6f1fd3c859b4936980923f204e80 WHIRLPOOL 1bb4a73678613dd6fe6b0d1225b3fd967fbb476e5736949846f3297febf727f41c9d3e71565b13dcc90d36d57a6cf012a3cdad509ed4364bb87de7e372c69a79
diff --git a/ros-meta/robot/metadata.xml b/ros-meta/robot/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/ros-meta/robot/robot-1.2.0.ebuild b/ros-meta/robot/robot-1.2.0.ebuild
new file mode 100644 (file)
index 0000000..075d3ba
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage which extends ros_base and includes ROS libaries for any robot hardware"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       ros-meta/ros_base
+       dev-ros/control_msgs
+       ros-meta/diagnostics
+       dev-ros/filters
+       ros-meta/geometry
+       ros-meta/robot_model
+       dev-ros/robot_state_publisher
+       dev-ros/xacro
+       ros-meta/executive_smach
+       dev-ros/actionlib
+       ros-meta/bond_core
+       dev-ros/class_loader
+       dev-ros/dynamic_reconfigure
+       ros-meta/common_tutorials
+       ros-meta/nodelet_core
+       dev-ros/pluginlib
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/robot/robot-9999.ebuild b/ros-meta/robot/robot-9999.ebuild
new file mode 100644 (file)
index 0000000..075d3ba
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage which extends ros_base and includes ROS libaries for any robot hardware"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       ros-meta/ros_base
+       dev-ros/control_msgs
+       ros-meta/diagnostics
+       dev-ros/filters
+       ros-meta/geometry
+       ros-meta/robot_model
+       dev-ros/robot_state_publisher
+       dev-ros/xacro
+       ros-meta/executive_smach
+       dev-ros/actionlib
+       ros-meta/bond_core
+       dev-ros/class_loader
+       dev-ros/dynamic_reconfigure
+       ros-meta/common_tutorials
+       ros-meta/nodelet_core
+       dev-ros/pluginlib
+"
+DEPEND="${RDEPEND}"