dev-python/requests-cache: Use distutils_enable_sphinx
authorMichał Górny <mgorny@gentoo.org>
Wed, 6 May 2020 05:22:33 +0000 (07:22 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 6 May 2020 06:03:54 +0000 (08:03 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/requests-cache/requests-cache-0.4.12-r1.ebuild

index 5ac6dc24a10a4c75472b99c91b91d29bfe165650..a209cefea5a911ae387df5b064621369d401a47d 100644 (file)
@@ -19,17 +19,8 @@ IUSE="doc"
 # Portage only has versions of request >= minimum border
 RDEPEND=">=dev-python/requests-2.6[${PYTHON_USEDEP}]"
 DEPEND="
-       app-arch/unzip
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+       app-arch/unzip"
 
+distutils_enable_sphinx docs
 # Testsuite excels in tests connecting to the network via local server daemons
 #distutils_enable_tests setup.py
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       distutils-r1_python_install_all
-}