dev-python/genty: Port to py3.9
authorMichał Górny <mgorny@gentoo.org>
Mon, 25 May 2020 19:32:16 +0000 (21:32 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 25 May 2020 19:48:04 +0000 (21:48 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/genty/genty-1.3.2.ebuild

index 68df7a34cfe06279c17b63993a60278703087d71..15cbbcc63c39d7ab773480f1f5531971785d9af2 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
 
 inherit distutils-r1
 
@@ -14,17 +14,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 SLOT="0"
 LICENSE="Apache-2.0"
 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
 
 RDEPEND="
        dev-python/six[${PYTHON_USEDEP}]
 "
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
        test? ( dev-python/mock[${PYTHON_USEDEP}] )
 "
 
-python_test() {
-       esetup.py test --verbose
-}
+distutils_enable_tests setup.py