Depend on avahi-daemon service, not avahi. Thanks to Tony Vroon for reporting.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Wed, 6 Sep 2006 21:56:18 +0000 (21:56 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Wed, 6 Sep 2006 21:56:18 +0000 (21:56 +0000)
Package-Manager: portage-2.1.1_rc1-r5

media-sound/pulseaudio/ChangeLog
media-sound/pulseaudio/files/digest-pulseaudio-0.9.5-r3 [new file with mode: 0644]
media-sound/pulseaudio/pulseaudio-0.9.5-r3.ebuild [new file with mode: 0644]

index 0e6c4aed665eeb48553e8595aace61415ebd6b30..d975c9d8e50aa3706bc38da15b99e583531d44f2 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for media-sound/pulseaudio
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.28 2006/09/05 21:21:47 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/ChangeLog,v 1.29 2006/09/06 21:56:17 flameeyes Exp $
+
+*pulseaudio-0.9.5-r3 (06 Sep 2006)
+
+  06 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+  -pulseaudio-0.9.5-r2.ebuild, +pulseaudio-0.9.5-r3.ebuild:
+  Depend on avahi-daemon service, not avahi. Thanks to Tony Vroon for reporting.
 
 *pulseaudio-0.9.5-r2 (05 Sep 2006)
 
diff --git a/media-sound/pulseaudio/files/digest-pulseaudio-0.9.5-r3 b/media-sound/pulseaudio/files/digest-pulseaudio-0.9.5-r3
new file mode 100644 (file)
index 0000000..0d68de7
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 99b5d9efd4fce35cabb4ae5d0ebb230d pulseaudio-0.9.5.tar.gz 1145930
+RMD160 67f0cef89588453e347a2af5f641c9f953d4ef4b pulseaudio-0.9.5.tar.gz 1145930
+SHA256 cd82eabcf9fa310a64b58b621730cebe5d3edae7596a9c121155db455b1e58f6 pulseaudio-0.9.5.tar.gz 1145930
diff --git a/media-sound/pulseaudio/pulseaudio-0.9.5-r3.ebuild b/media-sound/pulseaudio/pulseaudio-0.9.5-r3.ebuild
new file mode 100644 (file)
index 0000000..c9fa172
--- /dev/null
@@ -0,0 +1,119 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/pulseaudio/pulseaudio-0.9.5-r3.ebuild,v 1.1 2006/09/06 21:56:17 flameeyes Exp $
+
+inherit eutils libtool # autotools
+
+DESCRIPTION="A networked sound server with an advanced plugin system"
+HOMEPAGE="http://0pointer.de/lennart/projects/pulseaudio/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="alsa avahi caps jack lirc oss tcpd X hal"
+
+RDEPEND="X? ( || ( x11-libs/libX11 <virtual/x11-7 ) )
+       caps? ( sys-libs/libcap )
+       >=media-libs/audiofile-0.2.6-r1
+       >=media-libs/libsamplerate-0.1.1-r1
+       >=media-libs/libsndfile-1.0.10
+       >=dev-libs/liboil-0.3.6
+       alsa? ( >=media-libs/alsa-lib-1.0.10 )
+       >=dev-libs/glib-2.4.0
+       avahi? ( >=net-dns/avahi-0.6.12 )
+       >=dev-libs/liboil-0.3.0
+       jack? ( >=media-sound/jack-audio-connection-kit-0.100 )
+       tcpd? ( sys-apps/tcp-wrappers )
+       lirc? ( app-misc/lirc )
+       hal? ( >=sys-apps/hal-0.5.7 )
+       app-admin/eselect-esd"
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig"
+
+pkg_setup() {
+       if use avahi && ! built_with_use net-dns/avahi dbus ; then
+               echo
+               eerror "In order to compile pulseaudio with avahi support, you need to have"
+               eerror "net-dns/avahi emerged with 'dbus' in your USE flag. Please add that"
+               eerror "flag, re-emerge avahi, and then emerge pulseaudio again."
+               die "net-dns/avahi is missing the D-Bus bindings."
+       fi
+
+       enewgroup audio 18 # Just make sure it exists
+       enewgroup pulse-access
+       enewgroup pulse
+       enewuser pulse -1 -1 /var/run/pulse pulse,audio
+}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       epatch "${FILESDIR}/${P}-esdcompat.patch"
+       epatch "${FILESDIR}/${P}-fbsd.patch"
+
+       # eautoreconf
+       elibtoolize
+}
+
+src_compile() {
+       econf \
+               --enable-largefile \
+               --enable-glib2 \
+               --disable-solaris \
+               --disable-asyncns \
+               $(use_enable oss) \
+               $(use_enable alsa) \
+               $(use_enable lirc) \
+               $(use_enable tcpd tcpwrap) \
+               $(use_enable jack) \
+               $(use_enable lirc) \
+               $(use_enable avahi) \
+               $(use_enable hal) \
+               $(use_with caps) \
+               $(use_with X x) \
+               --disable-ltdl-install \
+               --localstatedir=/var \
+               || die "econf failed"
+       emake || die "emake failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "make install failed"
+
+       newconfd "${FILESDIR}/pulseaudio.conf.d" pulseaudio
+
+       local neededservices
+       use alsa && neededservices="$neededservices alsasound"
+       use avahi && neededservices="$neededservices avahi-daemon"
+       use hal && neededservices="$neededservices hald"
+       [[ -n ${neededservices} ]] && sed -e "s/@neededservices@/need $neededservices/" "${FILESDIR}/pulseaudio.init.d-2" > "${T}/pulseaudio"
+       doinitd "${T}/pulseaudio"
+
+       if ! use hal; then
+               sed -i -e '/module-hal-detect/s:^:#: ; /module-detect/s:^#::' "${D}/etc/pulse/default.pa"
+       fi
+
+       dohtml -r doc
+       dodoc README
+
+       # Create the state directory
+       diropts -o pulse -g pulse -m0755
+       keepdir /var/run/pulse
+}
+
+pkg_postinst() {
+       elog "PulseAudio in Gentoo can use a system-wide pulseaudio daemon."
+       elog "This support is enabled by starting the pulsedaemon init.d ."
+       elog "To be able to access that you need to be in the group pulse-access."
+       elog "For more information about system-wide support, please refer to"
+       elog "   http://pulseaudio.org/wiki/SystemWideInstance"
+
+       elog "To use the ESounD wrapper while using a system-wide daemon, you also"
+       elog "need to enable auth-anonymous for the esound-unix module, or to copy"
+       elog "/var/run/pulse/.esd_auth into each home directory."
+
+       eselect esd update --if-unset
+}