sys-apps/shadow: Ensure /bin is present before moving file into it
authorSargun Dhillon <sargun@sargun.me>
Mon, 8 Oct 2018 06:52:07 +0000 (23:52 -0700)
committerMike Gilbert <floppym@gentoo.org>
Mon, 8 Oct 2018 17:36:14 +0000 (13:36 -0400)
When building with a new prefix, sometimes the /bin directory
does not exist at install time. Therefore, we need to create it
before using it.

You can recreate if you try to run:
emerge --prefix=/test shadow

Closes: https://github.com/gentoo/gentoo/pull/10107
Signed-off-by: Sargun Dhillon <sargun@sargun.me>
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
sys-apps/shadow/shadow-4.6.ebuild

index 2c4f91f2ecd868fe8bf259c1a9f124890acad3fe..6c3e7bef5d762eb471ebda3bbed18be2ef85b1d5 100644 (file)
@@ -110,6 +110,7 @@ src_install() {
        doins "${FILESDIR}"/default/useradd
 
        # move passwd to / to help recover broke systems #64441
+       dodir /bin
        mv "${ED%/}"/usr/bin/passwd "${ED%/}"/bin/ || die
        dosym ../../bin/passwd /usr/bin/passwd