media-video/gaupol: bump to 1.8, add Python 3.8 support
authorLouis Sautier <sbraz@gentoo.org>
Sun, 12 Apr 2020 15:59:11 +0000 (17:59 +0200)
committerLouis Sautier <sbraz@gentoo.org>
Sun, 12 Apr 2020 16:03:46 +0000 (18:03 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
media-video/gaupol/Manifest
media-video/gaupol/gaupol-1.8.ebuild [new file with mode: 0644]

index f9f52f2b20cc52e83bc7c9e9834208a284639860..9a0ed242ba32a6b6911261e622178539bb50c9a1 100644 (file)
@@ -1,3 +1,4 @@
 DIST gaupol-1.5.tar.gz 537279 BLAKE2B 1ba8644b49832ee80e61bf304b7978275064acbe2e5e733a991b280f947c4064f0d4f385055e580bd3aa2d9ee2291d64fd1ee4bd8a1ba4f8eaaaaf9a137085ff SHA512 48f3eda460c2fb3e4bdaf52c42645599f0d5ce8eae05f7a2a9c608192a27a8b86b83830584216dc73105968f544aeab30e171b2c176d9a3f5047e93510413b85
 DIST gaupol-1.6.tar.gz 540186 BLAKE2B 4e7a2e0c01be2ac88c0ae5948d3002005c72418ef21835195daf6b0c5b71d970006b0f76fa78a1ec7337d1f9366436c44eb336e0a56d8cbb7eac905e09d4c81a SHA512 e0f258b579a34644e54456978df9c5a6f72aa019b6de79918fe6892bb59d2316c3fc093f2f49c60d6eef74832fa2a9a9e102bb1d25f64f3143fd29d3cb4966e5
 DIST gaupol-1.7.tar.gz 524231 BLAKE2B 5f1c07a6d633fba53361ad4d9e1cdbc3236614a444bb387378c9e1ec6b358796eb7477168caace4b6101e0e6e0b83f10a2d3052acb5e0b0ab69e75f2b24db7fa SHA512 b0fa7f5216f47075aefddd58ab3aa1186265b5d70f8b4e7f7e252a1cc05bd1c4838c2af8efb4da39c0196f63dc3a64ff2269a458e2d95072606b59b4b8cada1b
+DIST gaupol-1.8.tar.gz 558627 BLAKE2B a7243310b97fe7187311585762faaff512364ca043630eb43c1ee99c55fa5400e14698e391b410b67f70f1bc7a741adb0737868d7b40c868bb4c6badacd14fb1 SHA512 a6b65316b5750a4d636b39b75393b0b2f2c44d978f1fc8cc3bd2cd2d2bcf9ba68d0161afb41bdca5b381ec39e5a2e06440f4f4676f344019966b297c4112e691
diff --git a/media-video/gaupol/gaupol-1.8.ebuild b/media-video/gaupol/gaupol-1.8.ebuild
new file mode 100644 (file)
index 0000000..9fa5bf5
--- /dev/null
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="A subtitle editor for text-based subtitles"
+HOMEPAGE="https://otsaloma.io/gaupol/"
+SRC_URI="https://github.com/otsaloma/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="spell test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       app-text/iso-codes
+       dev-python/chardet[${PYTHON_USEDEP}]
+       dev-python/pygobject:3[${PYTHON_USEDEP}]
+       x11-libs/gtk+:3[introspection]
+       spell? ( app-text/gspell[introspection] )
+"
+DEPEND="
+       sys-devel/gettext
+       test? (
+               ${RDEPEND}
+               app-dicts/myspell-en
+               app-text/enchant[hunspell]
+               app-text/gspell[introspection]
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )
+"
+
+DOCS=( AUTHORS.md NEWS.md TODO.md README.md README.aeidon.md )
+
+python_test() {
+       virtx pytest -vv
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       if [[ -z ${REPLACING_VERSIONS} ]]; then
+               elog "Previewing support requires MPV, MPlayer or VLC."
+               if use spell; then
+                       elog ""
+                       elog "Spell-checking requires a dictionary, any of app-dicts/myspell-*"
+                       elog "or app-text/aspell with the appropriate L10N variable."
+                       elog ""
+                       elog "Additionally, make sure that app-text/enchant has the correct flags enabled:"
+                       elog "USE=hunspell for myspell dictionaries and USE=aspell for aspell dictionaries."
+               fi
+       fi
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+}