ver bump
authorMike Frysinger <vapier@gentoo.org>
Fri, 2 Jan 2004 00:44:49 +0000 (00:44 +0000)
committerMike Frysinger <vapier@gentoo.org>
Fri, 2 Jan 2004 00:44:49 +0000 (00:44 +0000)
games-roguelike/tome/ChangeLog
games-roguelike/tome/files/digest-tome-2.2.5 [new file with mode: 0644]
games-roguelike/tome/tome-2.2.5.ebuild [new file with mode: 0644]

index 3175c7b17fb4b80d1330176cc2d69208ea9709df..b917d9b075c7ae799c45fc98e363be8df360767a 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for games-roguelike/tome
 # Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/ChangeLog,v 1.3 2003/10/13 20:04:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/ChangeLog,v 1.4 2004/01/02 00:44:47 vapier Exp $
+
+*tome-2.2.5 (01 Jan 2004)
+
+  01 Jan 2004; Mike Frysinger <vapier@gentoo.org> :
+  Version bumpage #36798.
 
 *tome-2.2.3 (13 Oct 2003)
 
diff --git a/games-roguelike/tome/files/digest-tome-2.2.5 b/games-roguelike/tome/files/digest-tome-2.2.5
new file mode 100644 (file)
index 0000000..72f8f65
--- /dev/null
@@ -0,0 +1 @@
+MD5 b1a340a6092fd53b07be9d107b16e16b tome-225-src.tgz 3179754
diff --git a/games-roguelike/tome/tome-2.2.5.ebuild b/games-roguelike/tome/tome-2.2.5.ebuild
new file mode 100644 (file)
index 0000000..1e6ea3e
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/tome/tome-2.2.5.ebuild,v 1.1 2004/01/02 00:44:47 vapier Exp $
+
+inherit games
+
+MY_PV=${PV//./}
+DESCRIPTION="save the world from Morgoth and battle evil (or become evil ;])"
+HOMEPAGE="http://t-o-m-e.net/"
+SRC_URI="http://t-o-m-e.net/dl/src/tome-${MY_PV}-src.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+
+RDEPEND="virtual/glibc
+       >=sys-libs/ncurses-5
+       virtual/x11"
+
+S=${WORKDIR}/tome-${MY_PV}-src
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}/src
+       mv makefile.std makefile
+}
+
+src_compile() {
+       cd src
+       emake -j1 \
+               COPTS="${CFLAGS}" \
+               BINDIR=${GAMES_BINDIR} \
+               LIBDIR=${GAMES_DATADIR}/${PN} \
+               || die "emake failed"
+}
+
+src_install() {
+       cd src
+       emake -j1 \
+               OWNER=${GAMES_USER} \
+               BINDIR=${D}/${GAMES_BINDIR} \
+               LIBDIR=${D}/${GAMES_DATADIR}/${PN} install \
+               || die "make install failed"
+       cd ${S}
+       dodoc *.txt
+
+       prepgamesdirs
+       touch ${D}/${GAMES_DATADIR}/${PN}/apex/scores.raw
+       fperms g+w ${GAMES_DATADIR}/${PN}/apex/scores.raw
+       fperms g+w ${GAMES_DATADIR}/${PN}/data
+}
+
+pkg_postinst() {
+       games_pkg_postinst
+       echo
+       ewarn "ToME ${PV} is not save-game compatible with previous versions."
+       echo
+       einfo "If you have older save files and you wish to continue those games,"
+       einfo "you'll need to remerge the version of ToME with which you started"
+       einfo "those save-games."
+}