Version bumped. Closes 37995
authorMartin Holzer <mholzer@gentoo.org>
Wed, 14 Jan 2004 00:21:03 +0000 (00:21 +0000)
committerMartin Holzer <mholzer@gentoo.org>
Wed, 14 Jan 2004 00:21:03 +0000 (00:21 +0000)
app-editors/mp/Manifest
app-editors/mp/files/digest-mp-3.2.10 [new file with mode: 0644]
app-editors/mp/mp-3.2.10.ebuild [new file with mode: 0644]

index 36661f0ac883c23ddb908dbd48d13e276351fc61..165d6d35f471431e35491f5283911375920357ac 100644 (file)
@@ -1,8 +1,8 @@
-MD5 581814178810df8cf0d77c15df8a4fbe ChangeLog 882
+MD5 912fbf631496c1f901e78195ad6166f4 ChangeLog 1011
 MD5 f8960c09f9b4a97feeb5bc94a2b63943 mp-3.1.9.ebuild 706
 MD5 9089c0d93e6ae633c3aed330844ff6a3 mp-3.2.7.ebuild 701
 MD5 f7421079be18d530fa471d8ca9efa040 mp-3.2.8.ebuild 1001
-MD5 1da08e0aa9ea65bd24640632a06e61ad mp-3.2.10.ebuild 953
+MD5 a7f71a8a9b6f38ef9e6f7a352faa4ac1 mp-3.2.10.ebuild 1048
 MD5 ef0f5c3d7fae6d678f94005df3d90866 files/digest-mp-3.2.10 61
 MD5 135880e17116622cd1cfff6f0b370a29 files/digest-mp-3.1.9 59
 MD5 11b6a12f8308d146aabfd13282344f19 files/digest-mp-3.2.7 60
diff --git a/app-editors/mp/files/digest-mp-3.2.10 b/app-editors/mp/files/digest-mp-3.2.10
new file mode 100644 (file)
index 0000000..5fb4565
--- /dev/null
@@ -0,0 +1 @@
+MD5 33e94de620b4505895f20e5208f40ad3 mp-3.2.10.tar.gz 186696
diff --git a/app-editors/mp/mp-3.2.10.ebuild b/app-editors/mp/mp-3.2.10.ebuild
new file mode 100644 (file)
index 0000000..4435bcf
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.10.ebuild,v 1.1 2004/01/14 00:20:44 mholzer Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="mp, the definitive text editor"
+SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
+HOMEPAGE="http://www.triptico.com/software/mp.html"
+
+DEPEND="virtual/glibc
+       ncurses? ( sys-libs/ncurses )
+       gtk? ( =x11-libs/gtk+-1.2* )"
+
+RDEPEND="${DEPEND}
+       dev-lang/perl"
+IUSE="ncurses gtk"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+src_compile() {
+       if [ -n "`use ncurses`" ] && [ -n "`use gtk`" ]; then emake || die;
+       elif [ -n "`use ncurses`" ]; then emake mp || die;
+       elif [ -n "`use gtk`" ]; then emake gmp || die;
+       else die "You need ncurses and/or gtk in your USE variables";
+       fi
+}
+
+src_install () {
+       dodir /usr/bin
+       make install PREFIX=${D}/usr || die "install failed"
+       dodoc AUTHORS Changelog COPYING README
+       dohtml README.html doc/mp_api.html
+
+       insinto /usr/share/pixmaps/
+       doins mp.xpm
+}