net-p2p/ctorrent: Add missing <sys/types.h> include
authorDavid Seifert <soap@gentoo.org>
Sat, 21 Mar 2020 15:01:44 +0000 (16:01 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 21 Mar 2020 15:01:44 +0000 (16:01 +0100)
Closes: https://bugs.gentoo.org/713752
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: David Seifert <soap@gentoo.org>
net-p2p/ctorrent/ctorrent-3.3.2-r4.ebuild
net-p2p/ctorrent/files/ctorrent-3.3.2-sys-types_h.patch [new file with mode: 0644]

index 000a6838b530af34202c09ddeb0904c0f76cef47..85457d846cf6cfaa9c2ea61f590b25cb47726cbc 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 MY_P="${PN}-dnh${PV}"
 
@@ -14,16 +14,17 @@ SLOT="0"
 KEYWORDS="amd64 arm ppc ~s390 ~sh ~sparc x86"
 IUSE="libressl"
 
-S="${WORKDIR}/${MY_P}"
-
 RDEPEND="
        libressl? ( dev-libs/libressl:0= )
        !libressl? ( dev-libs/openssl:0= )
 "
 DEPEND="${RDEPEND}"
 
+S="${WORKDIR}/${MY_P}"
+
 PATCHES=(
        "${FILESDIR}"/${PN}-CVE-2009-1759.patch
        "${FILESDIR}"/${P}-negative-ints.patch
        "${FILESDIR}"/${P}-empty-path-components.patch
+       "${FILESDIR}"/${P}-sys-types_h.patch
 )
diff --git a/net-p2p/ctorrent/files/ctorrent-3.3.2-sys-types_h.patch b/net-p2p/ctorrent/files/ctorrent-3.3.2-sys-types_h.patch
new file mode 100644 (file)
index 0000000..bf93cb2
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/compat.c
++++ b/compat.c
+@@ -8,6 +8,8 @@
+ #include <sys/param.h>
+ #endif
++#include <sys/types.h>
++
+ #include "compat.h"
+ #ifndef HAVE_CLOCK_GETTIME