Version bump.
authorAndrej Kacian <ticho@gentoo.org>
Thu, 19 Apr 2007 14:54:56 +0000 (14:54 +0000)
committerAndrej Kacian <ticho@gentoo.org>
Thu, 19 Apr 2007 14:54:56 +0000 (14:54 +0000)
Package-Manager: portage-2.1.2.3

mail-client/claws-mail-pdf-viewer/ChangeLog
mail-client/claws-mail-pdf-viewer/claws-mail-pdf-viewer-0.4.ebuild [new file with mode: 0644]
mail-client/claws-mail-pdf-viewer/files/digest-claws-mail-pdf-viewer-0.4 [new file with mode: 0644]
mail-client/claws-mail/ChangeLog
mail-client/claws-mail/claws-mail-2.9.1.ebuild [new file with mode: 0644]
mail-client/claws-mail/files/digest-claws-mail-2.9.1 [new file with mode: 0644]

index c8af4b05d21c3b9d054495fce4e1445b55bb2ea8..b7da46fc7af24d3bc1d077291670504e0f724264 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for mail-client/claws-mail-pdf-viewer
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-pdf-viewer/ChangeLog,v 1.6 2007/04/16 13:17:45 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-pdf-viewer/ChangeLog,v 1.7 2007/04/19 14:54:56 ticho Exp $
+
+*claws-mail-pdf-viewer-0.4 (19 Apr 2007)
+
+  19 Apr 2007; Andrej Kacian <ticho@gentoo.org>
+  +claws-mail-pdf-viewer-0.4.ebuild:
+  Version bump.
 
 *claws-mail-pdf-viewer-0.3 (16 Apr 2007)
 
diff --git a/mail-client/claws-mail-pdf-viewer/claws-mail-pdf-viewer-0.4.ebuild b/mail-client/claws-mail-pdf-viewer/claws-mail-pdf-viewer-0.4.ebuild
new file mode 100644 (file)
index 0000000..33f5eb9
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-pdf-viewer/claws-mail-pdf-viewer-0.4.ebuild,v 1.1 2007/04/19 14:54:56 ticho Exp $
+
+MY_P="${P#claws-mail-}"
+MY_P="${MY_P/-/_}"
+
+DESCRIPTION=" Enables viewing of PDF and PostScript attachments using the Poppler lib and GhostScript"
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+DEPEND=">=mail-client/claws-mail-2.8.0
+               app-text/poppler-bindings"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+       make DESTDIR="${D}" install
+       dodoc AUTHORS ChangeLog NEWS README
+
+       # kill useless files
+       rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}
diff --git a/mail-client/claws-mail-pdf-viewer/files/digest-claws-mail-pdf-viewer-0.4 b/mail-client/claws-mail-pdf-viewer/files/digest-claws-mail-pdf-viewer-0.4
new file mode 100644 (file)
index 0000000..4728abf
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 eaf20191ea5a787e28e0573f4957aa37 pdf_viewer-0.4.tar.gz 395108
+RMD160 20feac5277cc33853f74f75bbb405eccc5a43b57 pdf_viewer-0.4.tar.gz 395108
+SHA256 2e2d1f9a1154d1ce71eabab36d9a3e885c9f9111f93da94576e5e30aefaa3735 pdf_viewer-0.4.tar.gz 395108
index 34bb558e6f76d690c6ecb608d5b19b3d80e69a18..ca18c615456f963288400798b46ab46e7dd241ae 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for mail-client/claws-mail
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.21 2007/04/16 11:33:59 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/ChangeLog,v 1.22 2007/04/19 14:52:30 ticho Exp $
+
+*claws-mail-2.9.1 (19 Apr 2007)
+
+  19 Apr 2007; Andrej Kacian <ticho@gentoo.org> +claws-mail-2.9.1.ebuild:
+  Version bump.
 
   16 Apr 2007; Andrej Kacian <ticho@gentoo.org> claws-mail-2.6.1.ebuild,
   claws-mail-2.7.0.ebuild, claws-mail-2.7.1.ebuild, claws-mail-2.7.2.ebuild,
diff --git a/mail-client/claws-mail/claws-mail-2.9.1.ebuild b/mail-client/claws-mail/claws-mail-2.9.1.ebuild
new file mode 100644 (file)
index 0000000..8132c93
--- /dev/null
@@ -0,0 +1,179 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail/claws-mail-2.9.1.ebuild,v 1.1 2007/04/19 14:52:30 ticho Exp $
+
+IUSE="gnome dillo crypt spell ssl ldap ipv6 pda clamav xface kde imap spamassassin doc startup-notification bogofilter"
+
+inherit eutils
+
+DESCRIPTION="Claws-Mail is an email client (and news reader) based on GTK+"
+HOMEPAGE="http://www.claws-mail.org"
+
+if [ -n "${P/*_rc*/}" ]; then
+       SRC_URI="mirror://sourceforge/sylpheed-claws/${P}.tar.bz2"
+else
+       MY_P="${P/_/-}"
+       S="${WORKDIR}/${MY_P}"
+       SRC_URI="http://www.claws-mail.org/snapshots/${MY_P}.tar.bz2"
+fi
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+COMMONDEPEND=">=x11-libs/gtk+-2.6
+       pda? ( >=app-pda/jpilot-0.99 )
+       ssl? ( >=dev-libs/openssl-0.9.7 )
+       ldap? ( >=net-nds/openldap-2.0.7 )
+       crypt? ( >=app-crypt/gpgme-1.1.1 )
+       dillo? ( www-client/dillo )
+       spell? ( virtual/aspell-dict )
+       clamav? ( app-antivirus/clamav )
+       kde? ( kde-base/kdelibs )
+       imap? ( >=net-libs/libetpan-0.49 )
+       gnome? ( >=gnome-base/libgnomeprintui-2.2 )
+       startup-notification? ( x11-libs/startup-notification )
+       bogofilter? ( mail-filter/bogofilter )
+       !<mail-client/sylpheed-claws-2.6.1"     # old name, block as user hint and due to some file collision
+
+DEPEND="${COMMONDEPEND}
+       xface? ( >=media-libs/compface-1.4 )
+       >=sys-apps/sed-4
+       dev-util/pkgconfig"
+
+RDEPEND="${COMMONDEPEND}
+       app-misc/mime-types
+       x11-misc/shared-mime-info"
+
+PLUGIN_NAMES="acpi-notifier att-remover cachesaver etpan-privacy fetchinfo gtkhtml maildir mailmbox newmail notification pdf-viewer perl rssyl smime synce vcalendar"
+
+src_compile() {
+       local myconf
+
+       # Optional features
+       myconf="${myconf} `use_enable gnome gnomeprint`"
+       myconf="${myconf} `use_enable imap libetpan`"
+       myconf="${myconf} `use_enable ipv6`"
+       myconf="${myconf} `use_enable ldap`"
+       myconf="${myconf} `use_enable pda jpilot`"
+       myconf="${myconf} `use_enable spell aspell`"
+       myconf="${myconf} `use_enable ssl openssl`"
+       myconf="${myconf} `use_enable xface compface`"
+       myconf="${myconf} `use_enable doc manual`"
+       myconf="${myconf} `use_enable startup-notification`"
+
+       # Optional plugins
+       myconf="${myconf} `use_enable clamav clamav-plugin`"
+       myconf="${myconf} `use_enable crypt pgpmime-plugin`"
+       myconf="${myconf} `use_enable crypt pgpinline-plugin`"
+       myconf="${myconf} `use_enable crypt pgpcore-plugin`"
+       myconf="${myconf} `use_enable dillo dillo-viewer-plugin`"
+       myconf="${myconf} `use_enable spamassassin spamassassin-plugin`"
+       myconf="${myconf} `use_enable bogofilter bogofilter-plugin`"
+
+       econf \
+               --enable-trayicon-plugin \
+               --disable-maemo \
+               ${myconf} || die "./configure failed"
+
+       emake || die
+}
+
+src_install() {
+       make DESTDIR=${D} install || die
+
+       # Makefile install claws-mail.png in /usr/share/icons/hicolor/48x48/apps
+       # => also install it in /usr/share/pixmaps for other desktop envs
+       # => also install higher resolution icons in /usr/share/icons/hicolor/...
+       insinto /usr/share/pixmaps
+       doins ${PN}.png || die
+       local res resdir
+       for res in 64x64 128x128 ; do
+               resdir="/usr/share/icons/hicolor/${res}/apps"
+               insinto ${resdir}
+               newins ${PN}-${res}.png ${PN}.png || die
+       done
+
+       dodoc AUTHORS ChangeLog* INSTALL* NEWS README* TODO*
+       docinto tools
+       dodoc tools/README*
+
+       insinto /usr/share/applications
+       doins ${PN}.desktop
+
+       einfo "Installing extra tools"
+       cd ${S}/tools
+       exeinto /usr/lib/${PN}/tools
+       doexe *.pl *.py *.rc *.conf *.sh || die
+       doexe tb2claws-mail update-po uudec uuooffice || die
+
+       if use kde; then
+               einfo "Installing kde service scripts"
+               local kdeprefix="$(kde-config --prefix)"
+               local servicescript="${PN}-kdeservicemenu.pl"
+               local desktopfile="${PN}-attach-files.desktop"
+               cd ${S}/tools/kdeservicemenu
+               sed -i -e "s:SCRIPT_PATH:${kdeprefix}/bin/${servicescript}:g" \
+                       template_${desktopfile}
+               dodir /usr/share/apps/konqueror/servicemenus
+               insopts -m 0644
+               insinto /usr/share/apps/konqueror/servicemenus
+               newins template_${desktopfile} ${desktopfile} || die
+               dodir ${kdeprefix}/bin
+               insopts -m 755
+               insinto ${kdeprefix}/bin
+               doexe ${servicescript} || die
+       fi
+
+       # kill useless plugin files
+       rm -f ${D}/usr/lib*/${PN}/plugins/*.{la,a}
+}
+
+pkg_postinst() {
+       gtk-update-icon-cache -f -t ${ROOT}/usr/share/icons/hicolor
+
+       UPDATE_PLUGINS=""
+       RENAME_PLUGINS=""
+       for x in ${PLUGIN_NAMES}; do
+               has_version mail-client/${PN}-$x && UPDATE_PLUGINS="${UPDATE_PLUGINS} $x"
+               has_version mail-client/sylpheed-claws-$x && RENAME_PLUGINS="${RENAME_PLUGINS} $x"
+       done
+       if [ -n "${RENAME_PLUGINS}" ]; then
+               elog
+               elog "The following sylpheed-claws plugins were found on your system:"
+               elog
+               for x in ${RENAME_PLUGINS}; do
+                       elog "    mail-client/sylpheed-claws-$x"
+               done
+               elog
+               elog "If you want to continue using those you need to merge their "
+               elog "renamed counterparts:"
+               elog
+               for x in ${RENAME_PLUGINS}; do
+                       elog "    mail-client/${PN}-$x"
+               done
+               elog
+       fi
+       if [ -n "${UPDATE_PLUGINS}" ]; then
+               elog
+               elog "You have to re-emerge or update the following plugins:"
+               elog
+               for x in ${UPDATE_PLUGINS}; do
+                       elog "    mail-client/${PN}-$x"
+               done
+               elog
+       fi
+       if [ -n "${RENAME_PLUGINS}${UPDATE_PLUGINS}" ]; then
+               elog
+               elog "You can use"
+               elog "    /bin/bash ${FILESDIR}/plugins-rebuild.sh"
+               elog "to automatically handle this."
+               elog
+               epause 5
+               ebeep 3
+       fi
+}
+
+pkg_postrm() {
+       gtk-update-icon-cache -f -t /usr/share/icons/hicolor
+}
diff --git a/mail-client/claws-mail/files/digest-claws-mail-2.9.1 b/mail-client/claws-mail/files/digest-claws-mail-2.9.1
new file mode 100644 (file)
index 0000000..eb1dfc9
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 c0e2718d4bcd932709a6e1bcc910c47a claws-mail-2.9.1.tar.bz2 5451118
+RMD160 19dc5b94e09a5d1f3c6812239daab78b64a651af claws-mail-2.9.1.tar.bz2 5451118
+SHA256 056500e4f61f28791390270636ef279c326b090c8634c15faa59497fb3086c8b claws-mail-2.9.1.tar.bz2 5451118