dev-cpp/tclap: version bump to 1.2.2.
authorFrederic Culot <culot@FreeBSD.org>
Tue, 21 Aug 2018 11:27:50 +0000 (13:27 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Wed, 22 Aug 2018 08:27:24 +0000 (10:27 +0200)
Closes: https://bugs.gentoo.org/664172
Closes: https://github.com/gentoo/gentoo/pull/9652

dev-cpp/tclap/Manifest
dev-cpp/tclap/metadata.xml
dev-cpp/tclap/tclap-1.2.2.ebuild [new file with mode: 0644]

index 392c55eef957de9e29cb9eb1e5498621f99c5207..95f59399a2f51549551114b3f74651f3a3588f08 100644 (file)
@@ -1 +1,2 @@
 DIST tclap-1.2.1.tar.gz 442387 BLAKE2B 413d77f59224dd7751621f32a5712178c4954cb532095203a1eb839c97d20e8651f94f90d4961a47f654d5b478946fb988db66df0d17c8230fde0b771af77405 SHA512 8bd6ee724600880840048c7b36f02d31b1aa4910b17f80fb04aef89b1f1917856d9979ec488edbd457b66d9d689aea97540abb842a8b902bbd75c66a6e07b9b1
+DIST tclap-1.2.2.tar.gz 231714 BLAKE2B 94fc3d5253c08a305e5f75f6b4b7ab556e94980193502b64665ff828609cde20f340e3fe18cef12011da07ae2db2c2bb52a08f112d052d74c45be8290d525092 SHA512 516ec17f82a61277922bc8c0ed66973300bf42a738847fbbd2912c6405c34f94a13e47dc964854a5b26a9a9f1f518cce682ca54e769d6016851656c647866107
index 71114a4fc927ef528075a1e8c56bc536edc5434c..f06935ec61de48c83dad4e3fe8bac3d9982fe951 100644 (file)
@@ -1,7 +1,14 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>gentoo@culot.org</email>
+               <name>Frederic Culot</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
        <upstream>
                <remote-id type="sourceforge">tclap</remote-id>
        </upstream>
diff --git a/dev-cpp/tclap/tclap-1.2.2.ebuild b/dev-cpp/tclap/tclap-1.2.2.ebuild
new file mode 100644 (file)
index 0000000..53fcd8f
--- /dev/null
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple templatized C++ library for parsing command line arguments"
+HOMEPAGE="http://tclap.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+       econf $(use_enable doc doxygen)
+}
+
+src_install() {
+       emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+}