app-editors/neovim: remove old
authorTim Harder <radhermit@gentoo.org>
Wed, 5 Feb 2020 08:45:12 +0000 (01:45 -0700)
committerTim Harder <radhermit@gentoo.org>
Wed, 5 Feb 2020 08:45:33 +0000 (01:45 -0700)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
app-editors/neovim/Manifest
app-editors/neovim/metadata.xml
app-editors/neovim/neovim-0.3.8.ebuild [deleted file]
app-editors/neovim/neovim-0.4.2.ebuild [deleted file]

index c6c0d92c7f0c0cd318ce65ade28bff11742b72a2..d94440938b40668900d29e0686a4626254e8477e 100644 (file)
@@ -1,3 +1 @@
-DIST neovim-0.3.8.tar.gz 9233661 BLAKE2B 252a64d2ac5ca1f8e1695d3f0f694ac333d9d9179dc4c428a279534e455de4b8d2c0dc6e638f775bb28a940fc1254bad426f7cee1bffaa2dbf84deefe49d41dc SHA512 431d3df859b430570e3f927328b862945a15b1ac041108599670d32af6cccac9361a143fc6af27847529629a43a5e0a0afd98b1c826d4ee1e7570de3cf14f9c7
-DIST neovim-0.4.2.tar.gz 9552134 BLAKE2B 4004a2e2788344ab96c97f145acc4f75680961ad004fcaa017731557899bbed24c6003b799c1496067a3ca75d8a4c2e63344b9646e8dab0ed00c9fa329d90ab2 SHA512 cc0de18ee7ca5105a0dd9f5f06b4d58335618b22c4dc3d584a024683785ff9d541c7f5131742b8a818ac9acb2218da92f9b8a881d56c4b963237918e589fac22
 DIST neovim-0.4.3.tar.gz 9556199 BLAKE2B 831f4d4950f4fa2cd9c7393824bbb5eb571ae5759d13af9f320e0fa351fa155413a5be580f010f2c7ab43ca7bc10c569ccf6e3ba29efc7f5a035576b030b216d SHA512 e13853fa296eda8618f389c71b6cbbd6f01d561615e80cc92959131dd10e395b1c6732a7d9ef6dbb9fe3ea9da4c11485b464547e2d46b22e59b8a20214e861f5
index 0a78b2540a2f41e295d7ad700a56869938e9980c..15cd5ba1c97d5a42a1996ca34b5f37a01de5e057 100644 (file)
@@ -14,9 +14,7 @@
                <name>Gentoo Vim Project</name>
        </maintainer>
        <use>
-               <flag name="clipboard">Enable clipboard support through a provider</flag>
                <flag name="nvimpager">Install nvimpager symlink to less.sh macro</flag>
-               <flag name="remote">Enable support for remote options using nvr</flag>
                <flag name="tui">Build the neovim unix tui</flag>
        </use>
        <upstream>
diff --git a/app-editors/neovim/neovim-0.3.8.ebuild b/app-editors/neovim/neovim-0.3.8.ebuild
deleted file mode 100644 (file)
index c96c308..0000000
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake xdg-utils
-
-DESCRIPTION="Vim-fork focused on extensibility and agility"
-HOMEPAGE="https://neovim.io"
-
-if [[ ${PV} == 9999 ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="https://github.com/neovim/neovim.git"
-else
-       SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm ~x86"
-fi
-
-LICENSE="Apache-2.0 vim"
-SLOT="0"
-IUSE="+clipboard +luajit +nvimpager python remote ruby +tui +jemalloc"
-
-BDEPEND="
-       dev-util/gperf
-       virtual/libiconv
-       virtual/libintl
-       virtual/pkgconfig
-"
-
-DEPEND="
-       dev-libs/libuv:0=
-       <dev-libs/libvterm-0.1
-       dev-libs/msgpack:0=
-       dev-lua/lpeg[luajit=]
-       dev-lua/mpack[luajit=]
-       net-libs/libnsl
-       jemalloc? ( dev-libs/jemalloc )
-       luajit? ( dev-lang/luajit:2 )
-       !luajit? (
-               dev-lang/lua:=
-               dev-lua/LuaBitOp
-       )
-       tui? (
-               dev-libs/libtermkey
-               >=dev-libs/unibilium-2.0.0:0=
-       )
-"
-
-RDEPEND="
-       ${DEPEND}
-       app-eselect/eselect-vi
-       python? ( dev-python/pynvim )
-       ruby? ( dev-ruby/neovim-ruby-client )
-       remote? ( dev-python/neovim-remote )
-       clipboard? ( || ( x11-misc/xsel x11-misc/xclip ) )
-"
-
-CMAKE_BUILD_TYPE=Release
-
-src_prepare() {
-       # use our system vim dir
-       sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
-               -i src/nvim/globals.h || die
-
-       cmake_src_prepare
-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DFEAT_TUI=$(usex tui)
-               -DENABLE_JEMALLOC=$(usex jemalloc)
-               -DPREFER_LUA=$(usex luajit no yes)
-       )
-       cmake_src_configure
-}
-
-src_install() {
-       cmake_src_install
-
-       # install a default configuration file
-       insinto /etc/vim
-       doins "${FILESDIR}"/sysinit.vim
-
-       # conditionally install a symlink for nvimpager
-       if use nvimpager; then
-               dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
-       fi
-}
-
-pkg_postinst() {
-       xdg_desktop_database_update
-}
-
-pkg_postrm() {
-       xdg_desktop_database_update
-}
diff --git a/app-editors/neovim/neovim-0.4.2.ebuild b/app-editors/neovim/neovim-0.4.2.ebuild
deleted file mode 100644 (file)
index 6077936..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake eutils xdg
-
-DESCRIPTION="Vim-fork focused on extensibility and agility."
-HOMEPAGE="https://neovim.io"
-
-if [[ ${PV} == 9999 ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="https://github.com/neovim/neovim.git"
-else
-       SRC_URI="https://github.com/neovim/neovim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="Apache-2.0 vim"
-SLOT="0"
-IUSE="+luajit +nvimpager +tui"
-
-BDEPEND="
-       dev-util/gperf
-       virtual/libiconv
-       virtual/libintl
-       virtual/pkgconfig
-"
-
-DEPEND="
-       dev-libs/libuv:0=
-       >=dev-libs/libvterm-0.1
-       dev-libs/msgpack:0=
-       dev-lua/lpeg[luajit=]
-       dev-lua/luv[luajit=]
-       dev-lua/mpack[luajit=]
-       net-libs/libnsl
-       luajit? ( dev-lang/luajit:2 )
-       !luajit? (
-               dev-lang/lua:=
-               dev-lua/LuaBitOp
-       )
-       tui? (
-               dev-libs/libtermkey
-               >=dev-libs/unibilium-2.0.0:0=
-       )
-"
-
-RDEPEND="
-       ${DEPEND}
-       app-eselect/eselect-vi
-"
-
-CMAKE_BUILD_TYPE=Release
-
-src_prepare() {
-       # use our system vim dir
-       sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
-               -i src/nvim/globals.h || die
-
-       cmake_src_prepare
-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DFEAT_TUI=$(usex tui)
-               -DPREFER_LUA=$(usex luajit no yes)
-       )
-       cmake_src_configure
-}
-
-src_install() {
-       cmake_src_install
-
-       # install a default configuration file
-       insinto /etc/vim
-       doins "${FILESDIR}"/sysinit.vim
-
-       # conditionally install a symlink for nvimpager
-       if use nvimpager; then
-               dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
-       fi
-}
-
-pkg_postinst() {
-       xdg_pkg_postinst
-       optfeature "clipboard support" x11-misc/xsel x11-misc/xclip gui-apps/wl-clipboard
-       optfeature "Python plugin support" dev-python/pynvim
-       optfeature "Ruby plugin support" dev-ruby/neovim-ruby-client
-       optfeature "remote/nvr support" dev-python/neovim-remote
-}