x11-drivers/nvidia-drivers: Fix conftest.sh locale expectations
authorJeroen Roovers <jer@gentoo.org>
Tue, 22 Oct 2019 09:11:51 +0000 (11:11 +0200)
committerJeroen Roovers <jer@gentoo.org>
Tue, 22 Oct 2019 09:17:21 +0000 (11:17 +0200)
conftest.sh in 440.* expects to find "$file: No such file or directory"
in compile test output for kernel headers, but with LC_ALL set, its
translations will not trigger that, resulting in false positives for
certain headers where the test intended to rule out false negatives.
Fix this by setting the default locale in conftest.sh.

Package-Manager: Portage-2.3.77, Repoman-2.3.17
Fixes: https://bugs.gentoo.org/698238
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
x11-drivers/nvidia-drivers/files/nvidia-drivers-440.26-locale.patch [new file with mode: 0644]
x11-drivers/nvidia-drivers/nvidia-drivers-440.26.ebuild

diff --git a/x11-drivers/nvidia-drivers/files/nvidia-drivers-440.26-locale.patch b/x11-drivers/nvidia-drivers/files/nvidia-drivers-440.26-locale.patch
new file mode 100644 (file)
index 0000000..aa2a743
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/kernel/conftest.sh
++++ b/kernel/conftest.sh
+@@ -6,6 +6,10 @@
+ SCRIPTDIR=`dirname $0`
+ cd $SCRIPTDIR
++# translate_and_compile_header_files() expects the default locale
++# https://bugs.gentoo.org/698238
++export LC_ALL=C
++
+ CC="$1"
+ ARCH=$2
+ ISYSTEM=`$CC -print-file-name=include 2> /dev/null`
index 2e87b035eecb3950eb501cc3d96e1c4d7067d4d1..529819532dc8fcfba0bf6c1af139cb105d775282 100644 (file)
@@ -83,6 +83,9 @@ RDEPEND="
 "
 QA_PREBUILT="opt/* usr/lib*"
 S=${WORKDIR}/
+PATCHES=(
+       "${FILESDIR}"/${PN}-440.26-locale.patch
+)
 
 nvidia_drivers_versions_check() {
        if use amd64 && has_multilib_profile && \