app-vim/youcompleteme: remove directory module only if it exists.
authorPatrice Clement <monsieurp@gentoo.org>
Fri, 3 Mar 2017 14:08:11 +0000 (15:08 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Fri, 3 Mar 2017 14:08:25 +0000 (15:08 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-vim/youcompleteme/youcompleteme-99999999.ebuild

index eb184f021961c6a2bada4a4ed638e5bfd5e57ea4..6ae3c704451bd3e4a65c318d620305df54a66994 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -56,15 +56,21 @@ CMAKE_USE_DIR=${S}/third_party/ycmd/cpp
 VIM_PLUGIN_HELPFILES="${PN}"
 
 src_prepare() {
-       if ! use test ; then
+       if ! use test; then
                sed -i '/^add_subdirectory( tests )/d' third_party/ycmd/cpp/ycm/CMakeLists.txt || die
        fi
+
        for third_party_module in requests pythonfutures; do
-               rm -r "${S}"/third_party/${third_party_module} || die "Failed to remove third party module ${third_party_module}"
+               if [[ -d "${third_party_module}" ]]; then
+                       rm -r "${S}"/third_party/${third_party_module} || die "Failed to remove third party module ${third_party_module}"
+               fi
        done
+
        # Argparse is included in python 2.7
        for third_party_module in argparse bottle jedi waitress sh requests; do
-               rm -r "${S}"/third_party/ycmd/third_party/${third_party_module} || die "Failed to remove third party module ${third_party_module}"
+               if [[ -d "${third_party_module}" ]]; then
+                       rm -r "${S}"/third_party/ycmd/third_party/${third_party_module} || die "Failed to remove third party module ${third_party_module}"
+               fi
        done
 }