dev-python/imapclient: Remove Py2
authorDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:12:55 +0000 (17:12 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:12:55 +0000 (17:12 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/imapclient/imapclient-0.13.ebuild
dev-python/imapclient/imapclient-2.1.0.ebuild

index 6d307b59f89fb683426d95127b0f1f9e038faa59..751ac20caba85851b1bee9ab38e7651307ad5297 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=5
 
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy )
+PYTHON_COMPAT=( python3_{5,6} )
 
 inherit distutils-r1
 
@@ -17,13 +17,11 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="amd64 x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
+IUSE="doc examples"
 
 RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy) )"
+       dev-python/setuptools[${PYTHON_USEDEP}]"
 
 S=${WORKDIR}/${MY_P}
 
index 5742007c853227248d955466796cd890f4379090..f38ee2f691f27d71e57bfec7a332f0f5334f995d 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+PYTHON_COMPAT=( python3_{5,6,7} )
 
 inherit distutils-r1
 
@@ -14,14 +14,12 @@ SRC_URI="https://github.com/mjs/imapclient/archive/${PV}.tar.gz -> ${P}.tar.gz"
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
+IUSE="doc examples"
 
 RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-       test? ( $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2) )"
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
 
 PATCHES=(
        # fix incorrect assumption about py3.6 behavior