net-mail/dovecot: security bump to 2.3.5.1
authorEray Aslan <eras@gentoo.org>
Fri, 29 Mar 2019 14:01:58 +0000 (17:01 +0300)
committerEray Aslan <eras@gentoo.org>
Fri, 29 Mar 2019 14:01:58 +0000 (17:01 +0300)
Bug: https://bugs.gentoo.org/681922
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Eray Aslan <eras@gentoo.org>
net-mail/dovecot/Manifest
net-mail/dovecot/dovecot-2.3.5.1.ebuild [new file with mode: 0644]

index 1afe06e12535539739159e0c6ffd904f78179b4b..04e2d3f047d21b091abe3bbf3fd44ba497b41a03 100644 (file)
@@ -12,4 +12,5 @@ DIST dovecot-2.3.2.1.tar.gz 6797491 BLAKE2B 92b88fd0f0cb8ed6c418bf27c2e1fc4efe13
 DIST dovecot-2.3.3.tar.gz 6851107 BLAKE2B 87d6e11c8ff59cfe0b49d3561c307535efb09296af617530a4d5a89b4fc12055d006d1b283a4de076f27d59deb64324b96f28620958ad85c38197710c5decdf7 SHA512 8666c4f92f7df883067540f85be9d03dbe6815b58a7f5de55b4292e986e9a2a1ef52c7e0c72dde2bc781fe40d57488b78a99b6b813745b8e4683f1a2fdc1f2ff
 DIST dovecot-2.3.4.1.tar.gz 6925073 BLAKE2B d8143bad01c107b68525d0cfc110e5bf4e3ffa0af49e7cafdfef263374e146a7ef6ed7107a7c5216c4b52da3640d7a9a80931c01d125d3852fa265171e4d4e09 SHA512 ff21aa0f0cae17dfa66617291688856727412defa48bad2b6be057cb509fbec1c2e134afbfee69929d06b8692a0fcbd8451671ba02860e1673ae1c9483c2c17e
 DIST dovecot-2.3.4.tar.gz 6924178 BLAKE2B 13e52a1b04036d58e68d762c9330dd5efedbf2421d658a8b657ca59e311b899a9b4a84fd754678ee67cd5b60f47b5a5ccd6a3fa08fafca7413c8b1e6ecd2fb51 SHA512 9e97eb08c319c417e8abcb430b3e6c87ed5aa820d6288656fdfd958ff34664f67202a66e4846763bfc85b309b116cea8012e49dab98b478c57974cc178a37a5a
+DIST dovecot-2.3.5.1.tar.gz 6953150 BLAKE2B 04484325e7b87f78c0aa6e3c769bc921e9dc62562cd8705b99166b7291b794f434b088dcf6512bc21c96d8937475cafa4d49c6ac611cb07f74a0d20e15e185c7 SHA512 e87754461fb0b065acd0ff10dc955000a2fe5baffed69efaf328ce9268f90140e9de444bc68e0bd48b565c7622885a79b1f90ff3dd2335c0c2362d05d9e73e8a
 DIST dovecot-2.3.5.tar.gz 6970480 BLAKE2B 006f64ce87e3eff04f3df7689ba9caed0b6b4f83eef28ee8fc2bafcf4a90b0255bf3d0d5d6b32571de8eb339f720a4d7b6de7dd5e3bcf6d03ecc5d6fa679799c SHA512 10513c371aeadd52184daaf8dbb9a7559c6db55e34182bbb2c9539dae0897ddcc76f6fe2ce6a81c7ce0cb94c7f79438ae3bb0e7db8ed46615feb337b4078ecc6
diff --git a/net-mail/dovecot/dovecot-2.3.5.1.ebuild b/net-mail/dovecot/dovecot-2.3.5.1.ebuild
new file mode 100644 (file)
index 0000000..96f60eb
--- /dev/null
@@ -0,0 +1,294 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# do not add a ssl USE flag.  ssl is mandatory
+SSL_DEPS_SKIP=1
+inherit autotools eapi7-ver ssl-cert systemd user
+
+MY_P="${P/_/.}"
+#MY_S="${PN}-ce-${PV}"
+major_minor="$(ver_cut 1-2)"
+sieve_version="0.5.5"
+if [[ ${PV} == *_rc* ]] ; then
+       rc_dir="rc/"
+else
+       rc_dir=""
+fi
+SRC_URI="https://dovecot.org/releases/${major_minor}/${rc_dir}${MY_P}.tar.gz
+       sieve? (
+       https://pigeonhole.dovecot.org/releases/${major_minor}/${rc_dir}${PN}-${major_minor}-pigeonhole-${sieve_version}.tar.gz
+       )
+       managesieve? (
+       https://pigeonhole.dovecot.org/releases/${major_minor}/${rc_dir}${PN}-${major_minor}-pigeonhole-${sieve_version}.tar.gz
+       ) "
+DESCRIPTION="An IMAP and POP3 server written with security primarily in mind"
+HOMEPAGE="https://www.dovecot.org/"
+
+SLOT="0"
+LICENSE="LGPL-2.1 MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IUSE_DOVECOT_AUTH="kerberos ldap lua mysql pam postgres sqlite vpopmail"
+IUSE_DOVECOT_COMPRESS="bzip2 lzma lz4 zlib"
+IUSE_DOVECOT_OTHER="argon2 caps doc ipv6 libressl lucene managesieve selinux sieve solr static-libs suid tcpd textcat"
+
+IUSE="${IUSE_DOVECOT_AUTH} ${IUSE_DOVECOT_STORAGE} ${IUSE_DOVECOT_COMPRESS} ${IUSE_DOVECOT_OTHER}"
+
+DEPEND="argon2? ( dev-libs/libsodium )
+       bzip2? ( app-arch/bzip2 )
+       caps? ( sys-libs/libcap )
+       kerberos? ( virtual/krb5 )
+       ldap? ( net-nds/openldap )
+       lua? ( dev-lang/lua:* )
+       lucene? ( >=dev-cpp/clucene-2.3 )
+       lzma? ( app-arch/xz-utils )
+       lz4? ( app-arch/lz4 )
+       mysql? ( dev-db/mysql-connector-c:0= )
+       pam? ( virtual/pam )
+       postgres? ( dev-db/postgresql:* !dev-db/postgresql[ldap,threads] )
+       selinux? ( sec-policy/selinux-dovecot )
+       solr? ( net-misc/curl dev-libs/expat )
+       sqlite? ( dev-db/sqlite:* )
+       !libressl? ( dev-libs/openssl:0 )
+       libressl? ( dev-libs/libressl )
+       tcpd? ( sys-apps/tcp-wrappers )
+       textcat? ( app-text/libexttextcat )
+       vpopmail? ( net-mail/vpopmail )
+       zlib? ( sys-libs/zlib )
+       virtual/libiconv
+       dev-libs/icu:="
+
+RDEPEND="${DEPEND}
+       net-mail/mailbase"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-userdb-passwd-fix.patch"
+)
+
+pkg_setup() {
+       if use managesieve && ! use sieve; then
+               ewarn "managesieve USE flag selected but sieve USE flag unselected"
+               ewarn "sieve USE flag will be turned on"
+       fi
+       # default internal user
+       enewgroup dovecot 97
+       enewuser dovecot 97 -1 /dev/null dovecot
+       # default login user
+       enewuser dovenull -1 -1 /dev/null
+       # add "mail" group for suid'ing. Better security isolation.
+       if use suid; then
+               enewgroup mail
+       fi
+}
+
+src_prepare() {
+       default
+       # bug 657108
+       # elibtoolize
+       eautoreconf
+}
+
+src_configure() {
+       local conf=""
+
+       if use postgres || use mysql || use sqlite; then
+               conf="${conf} --with-sql"
+       fi
+
+       # turn valgrind tests off. Bug #340791
+       VALGRIND=no econf \
+               --with-rundir="${EPREFIX}/run/dovecot" \
+               --with-statedir="${EPREFIX}/var/lib/dovecot" \
+               --with-moduledir="${EPREFIX}/usr/$(get_libdir)/dovecot" \
+               --without-stemmer \
+               --disable-rpath \
+               --without-libbsd \
+               --with-icu \
+               --with-ssl \
+               --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+               $( use_with argon2 sodium ) \
+               $( use_with bzip2 bzlib ) \
+               $( use_with caps libcap ) \
+               $( use_with kerberos gssapi ) \
+               $( use_with lua ) \
+               $( use_with ldap ) \
+               $( use_with lucene ) \
+               $( use_with lz4 ) \
+               $( use_with lzma ) \
+               $( use_with mysql ) \
+               $( use_with pam ) \
+               $( use_with postgres pgsql ) \
+               $( use_with sqlite ) \
+               $( use_with solr ) \
+               $( use_with tcpd libwrap ) \
+               $( use_with textcat ) \
+               $( use_with vpopmail ) \
+               $( use_with zlib ) \
+               $( use_enable static-libs static ) \
+               ${conf}
+
+       if use sieve || use managesieve ; then
+               # The sieve plugin needs this file to be build to determine the plugin
+               # directory and the list of libraries to link to.
+               emake dovecot-config
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               econf \
+                       $( use_enable static-libs static ) \
+                       --localstatedir="${EPREFIX%/}/var" \
+                       --enable-shared \
+                       --with-dovecot="${S}" \
+                       $( use_with managesieve )
+       fi
+}
+
+src_compile() {
+       default
+       if use sieve || use managesieve ; then
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+       fi
+}
+
+src_test() {
+       default
+       if use sieve || use managesieve ; then
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               default
+       fi
+}
+
+src_install () {
+       default
+
+       # insecure:
+       # use suid && fperms u+s /usr/libexec/dovecot/deliver
+       # better:
+       if use suid;then
+               einfo "Changing perms to allow deliver to be suided"
+               fowners root:mail "${EPREFIX}/usr/libexec/dovecot/dovecot-lda"
+               fperms 4750 "${EPREFIX}/usr/libexec/dovecot/dovecot-lda"
+       fi
+
+       newinitd "${FILESDIR}"/dovecot.init-r6 dovecot
+
+       rm -rf "${ED}"/usr/share/doc/dovecot
+
+       dodoc AUTHORS NEWS README TODO
+       dodoc doc/*.{txt,cnf,xml,sh}
+       docinto example-config
+       dodoc doc/example-config/*.{conf,ext}
+       docinto example-config/conf.d
+       dodoc doc/example-config/conf.d/*.{conf,ext}
+       docinto wiki
+       dodoc doc/wiki/*
+       doman doc/man/*.{1,7}
+
+       # Create the dovecot.conf file from the dovecot-example.conf file that
+       # the dovecot folks nicely left for us....
+       local conf="${ED}/etc/dovecot/dovecot.conf"
+       local confd="${ED}/etc/dovecot/conf.d"
+
+       insinto /etc/dovecot
+       doins doc/example-config/*.{conf,ext}
+       insinto /etc/dovecot/conf.d
+       doins doc/example-config/conf.d/*.{conf,ext}
+       fperms 0600 "${EPREFIX}"/etc/dovecot/dovecot-{ldap,sql}.conf.ext
+       rm -f "${confd}/../README"
+
+       # .maildir is the Gentoo default
+       local mail_location="maildir:~/.maildir"
+       sed -i -e \
+               "s|#mail_location =|mail_location = ${mail_location}|" \
+               "${confd}/10-mail.conf" \
+               || die "failed to update mail location settings in 10-mail.conf"
+
+       # We're using pam files (imap and pop3) provided by mailbase
+       if use pam; then
+               sed -i -e '/driver = pam/,/^[ \t]*}/ s|#args = dovecot|args = "\*"|' \
+                       "${confd}/auth-system.conf.ext" \
+                       || die "failed to update PAM settings in auth-system.conf.ext"
+               # mailbase does not provide a sieve pam file
+               use managesieve && dosym imap /etc/pam.d/sieve
+               sed -i -e \
+                       's/#!include auth-system.conf.ext/!include auth-system.conf.ext/' \
+                       "${confd}/10-auth.conf" \
+                       || die "failed to update PAM settings in 10-auth.conf"
+       fi
+
+       # Disable ipv6 if necessary
+       if ! use ipv6; then
+               sed -i -e 's/^#listen = \*, ::/listen = \*/g' "${conf}" \
+                       || die "failed to update listen settings in dovecot.conf"
+       fi
+
+       # Update ssl cert locations
+       sed -i -e 's:^#ssl = yes:ssl = yes:' "${confd}/10-ssl.conf" \
+               || die "ssl conf failed"
+       sed -i -e 's:^ssl_cert =.*:ssl_cert = </etc/ssl/dovecot/server.pem:' \
+               -e 's:^ssl_key =.*:ssl_key = </etc/ssl/dovecot/server.key:' \
+               "${confd}/10-ssl.conf" || die "failed to update SSL settings in 10-ssl.conf"
+
+       # Install SQL configuration
+       if use mysql || use postgres; then
+               sed -i -e \
+                       's/#!include auth-sql.conf.ext/!include auth-sql.conf.ext/' \
+                       "${confd}/10-auth.conf" || die "failed to update SQL settings in \
+                       10-auth.conf"
+       fi
+
+       # Install LDAP configuration
+       if use ldap; then
+               sed -i -e \
+                       's/#!include auth-ldap.conf.ext/!include auth-ldap.conf.ext/' \
+                       "${confd}/10-auth.conf" \
+                       || die "failed to update ldap settings in 10-auth.conf"
+       fi
+
+       if use vpopmail; then
+               sed -i -e \
+                       's/#!include auth-vpopmail.conf.ext/!include auth-vpopmail.conf.ext/' \
+                       "${confd}/10-auth.conf" \
+                       || die "failed to update vpopmail settings in 10-auth.conf"
+       fi
+
+       if use sieve || use managesieve ; then
+               cd "../dovecot-${major_minor}-pigeonhole-${sieve_version}" || die "cd failed"
+               emake DESTDIR="${ED}" install
+               sed -i -e \
+                       's/^[[:space:]]*#mail_plugins = $mail_plugins/mail_plugins = sieve/' "${confd}/15-lda.conf" \
+                       || die "failed to update sieve settings in 15-lda.conf"
+               rm -rf "${ED}"/usr/share/doc/dovecot
+               docinto example-config/conf.d
+               dodoc doc/example-config/conf.d/*.conf
+               insinto /etc/dovecot/conf.d
+               doins doc/example-config/conf.d/90-sieve{,-extprograms}.conf
+               use managesieve && doins doc/example-config/conf.d/20-managesieve.conf
+               docinto sieve/rfc
+               dodoc doc/rfc/*.txt
+               docinto sieve/devel
+               dodoc doc/devel/DESIGN
+               docinto plugins
+               dodoc doc/plugins/*.txt
+               docinto extensions
+               dodoc doc/extensions/*.txt
+               docinto locations
+               dodoc doc/locations/*.txt
+               doman doc/man/*.{1,7}
+       fi
+
+       use static-libs || find "${ED}"/usr/lib* -name '*.la' -delete
+}
+
+pkg_postinst() {
+       # Let's not make a new certificate if we already have one
+       if ! [[ -e "${ROOT}"/etc/ssl/dovecot/server.pem && \
+               -e "${ROOT}"/etc/ssl/dovecot/server.key ]];     then
+               einfo "Creating SSL     certificate"
+               SSL_ORGANIZATION="${SSL_ORGANIZATION:-Dovecot IMAP Server}"
+               install_cert /etc/ssl/dovecot/server
+       fi
+
+       elog "Please read http://wiki2.dovecot.org/Upgrading/ for upgrade notes."
+}