Revert "dev-python/requests-cache: Drop old"
authorMikle Kolyada <zlogene@gentoo.org>
Thu, 7 May 2020 13:31:47 +0000 (16:31 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Thu, 7 May 2020 13:51:17 +0000 (16:51 +0300)
This reverts commit 57fc84fdd745bd31fcf9fc9d0652a7d8743d5849.

Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-python/requests-cache/requests-cache-0.4.12.ebuild [new file with mode: 0644]

diff --git a/dev-python/requests-cache/requests-cache-0.4.12.ebuild b/dev-python/requests-cache/requests-cache-0.4.12.ebuild
new file mode 100644 (file)
index 0000000..fbebcee
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_6 )
+
+inherit distutils-r1
+
+HOMEPAGE="https://pypi.org/project/requests-cache/"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+# Portage only has versions of request >= minimum border
+RDEPEND=">=dev-python/requests-2.6[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Testsuite excels in tests connecting to the network via local server daemons
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+       distutils-r1_python_install_all
+}