app-accessibility/orca: bump to 3.34.2
authorMart Raudsepp <leio@gentoo.org>
Sun, 29 Mar 2020 17:47:25 +0000 (20:47 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 29 Mar 2020 17:55:55 +0000 (20:55 +0300)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
app-accessibility/orca/Manifest
app-accessibility/orca/orca-3.34.2.ebuild [new file with mode: 0644]

index d264ba129430ce49d6dd4922b009b98b7d8de2c8..386583e67ad2fd0dc08db820be41c8f09f1b6f71 100644 (file)
@@ -1 +1,2 @@
 DIST orca-3.32.0.tar.xz 2512032 BLAKE2B eae6c726e5e7361b7d60f0907f8c62c476895d681cf424940586e6308bcde147094a9557243aae6ecffef142bd556cb3cb30839955403e0958f123672400bf0a SHA512 015aa26ddaffa53d646e5d708ffed9e771beebbe925c27b963cbd3c3a2b36f730c0668cac6b89a371cd81cf8a570eb591711ba923fa4d013e00e31667749cf20
+DIST orca-3.34.2.tar.xz 3509556 BLAKE2B 4e73517660b837cec6d4dc12e3b2e57dec526f22aa407ababee2cb12c3aa8807184649b6962f26551926b1b3f8c49230054b4ef5583e15eeeb94685aaaf3ca13 SHA512 b685bd8e417d74ccc0d0ce6b15b3220e5079320198886f568147480f107f7d0273cbd412fdc2c6cc509d3210b36c40aecb50e167d43120f6770ce02a0891ad20
diff --git a/app-accessibility/orca/orca-3.34.2.ebuild b/app-accessibility/orca/orca-3.34.2.ebuild
new file mode 100644 (file)
index 0000000..0b1b19b
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="threads"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+       >=app-accessibility/at-spi2-atk-2.32:2
+       >=app-accessibility/at-spi2-core-2.32:2[introspection]
+       >=dev-libs/atk-2.32
+       >=dev-libs/glib-2.28:2
+       media-libs/gstreamer:1.0[introspection]
+       >=x11-libs/gtk+-3.6.2:3[introspection]
+       $(python_gen_cond_dep '
+               dev-python/gst-python:1.0[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/pygobject-3.18:3[${PYTHON_MULTI_USEDEP}]
+       ')
+       braille? (
+               $(python_gen_cond_dep '
+                       >=app-accessibility/brltty-5.0-r3[python,${PYTHON_MULTI_USEDEP}]
+                       dev-libs/liblouis[python,${PYTHON_MULTI_USEDEP}]
+               ')
+       )
+"
+RDEPEND="${COMMON_DEPEND}
+       dev-libs/atk[introspection]
+       $(python_gen_cond_dep '
+               >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_MULTI_USEDEP}]
+               >=dev-python/pyatspi-2.32[${PYTHON_MULTI_USEDEP}]
+               dev-python/setproctitle[${PYTHON_MULTI_USEDEP}]
+       ')
+       x11-libs/libwnck:3[introspection]
+       x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+       dev-util/itstool
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+#      app-text/yelp-tools
+
+src_configure() {
+       gnome2_src_configure \
+               $(use_with braille liblouis)
+}