dev-python/pastedeploy: Set DISTUTILS_USE_SETUPTOOLS
authorMichał Górny <mgorny@gentoo.org>
Mon, 27 Jan 2020 06:40:33 +0000 (07:40 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 27 Jan 2020 07:22:11 +0000 (08:22 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pastedeploy/pastedeploy-2.0.1-r1.ebuild

index d16669ada327e7781777f03269128e5de22e38c4..c0cab0d1ae9a61a62dfc5604bfb178e33ddca56e 100644 (file)
@@ -2,6 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
 PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
 
 inherit distutils-r1
@@ -19,8 +21,7 @@ SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
 IUSE="doc"
 
-RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]"
 BDEPEND="${RDEPEND}"
 
 distutils_enable_tests pytest