dont compress manpage
authorMike Frysinger <vapier@gentoo.org>
Fri, 26 Jan 2007 08:31:44 +0000 (08:31 +0000)
committerMike Frysinger <vapier@gentoo.org>
Fri, 26 Jan 2007 08:31:44 +0000 (08:31 +0000)
Package-Manager: portage-2.1.2-r3

games-arcade/solarwolf/solarwolf-1.5.ebuild
games-arcade/tuxpuck/files/digest-tuxpuck-0.8.2
games-arcade/tuxpuck/tuxpuck-0.8.2.ebuild

index 87821c3ca636c25f9b44c90323af32a4f09899a1..72547ae2ae1b49ebb6014dde1edee10165b75f99 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/solarwolf-1.5.ebuild,v 1.14 2006/09/27 16:30:34 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/solarwolf-1.5.ebuild,v 1.15 2007/01/26 08:30:31 vapier Exp $
 
 inherit eutils games
 
@@ -26,12 +26,14 @@ pkg_setup() {
 
 src_unpack() {
        unpack ${A}
-       find "${S}" -name .xvpics -print0 | xargs -0 rm -fr
+       cd "${S}"
+       find . -name .xvpics -print0 | xargs -0 rm -fr
+       gunzip dist/solarwolf.6.gz || die
 }
 
 src_install() {
        dodoc readme.txt
-       doman dist/solarwolf.6.gz
+       doman dist/solarwolf.6
        dodir "${GAMES_LIBDIR}/${PN}"
        cp -r code/ data/ *py "${D}/${GAMES_LIBDIR}/${PN}/" || die "cp failed"
        games_make_wrapper solarwolf "python ./solarwolf.py" "${GAMES_LIBDIR}/${PN}"
index f1eb2266a6dd4a90659b72dd1e48345c2ba9491c..b653a3f857c6ba4040888be5f3e43145c5180d55 100644 (file)
@@ -1 +1,3 @@
 MD5 fc839abc2b1f3eafae397e1ed6487079 tuxpuck-0.8.2.tar.gz 384009
+RMD160 806b89030416d9b8ac2ed1eca003445cf07e3c4e tuxpuck-0.8.2.tar.gz 384009
+SHA256 62d9604ed69c27b9ca2be1312bc705b36de8ed509c539c6d81193e7846272f18 tuxpuck-0.8.2.tar.gz 384009
index 3ebfa2c00eee834cbc222746765c700363919183..20a7c9f330f86624f48fa3b909caec7041761689 100644 (file)
@@ -1,12 +1,12 @@
 # Copyright 1999-2005 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxpuck/tuxpuck-0.8.2.ebuild,v 1.6 2005/05/21 17:10:39 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/tuxpuck/tuxpuck-0.8.2.ebuild,v 1.7 2007/01/26 08:31:44 vapier Exp $
 
 inherit games
 
 DESCRIPTION="Hover hockey"
-SRC_URI="http://www.efd.lth.se/~d00jkr/tuxpuck/${P}.tar.gz"
 HOMEPAGE="http://www.efd.lth.se/~d00jkr/tuxpuck/"
+SRC_URI="http://www.efd.lth.se/~d00jkr/tuxpuck/${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
@@ -17,6 +17,12 @@ DEPEND=">=media-libs/libsdl-1.1.5
        media-libs/libpng
        >=media-libs/libvorbis-1.0_rc3"
 
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       gunzip man/tuxpuck.6.gz || die
+}
+
 src_compile() {
        # Note that the Makefiles for tuxpuck are buggy so -j1 is used.
        emake -j1 CPP_FLAGS="${CPPFLAGS} -I/usr/include/libpng12" || die
@@ -24,7 +30,7 @@ src_compile() {
 
 src_install() {
        dogamesbin tuxpuck || die "dogamesbin failed"
-       doman man/tuxpuck.6.gz
+       doman man/tuxpuck.6
        dodoc *.txt
        prepgamesdirs
 }