dev-python/websockets: New package required by pychess
authorJames Le Cuirot <chewi@gentoo.org>
Sat, 25 Apr 2020 15:04:35 +0000 (16:04 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 25 Apr 2020 15:48:20 +0000 (16:48 +0100)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
dev-python/websockets/Manifest [new file with mode: 0644]
dev-python/websockets/metadata.xml [new file with mode: 0644]
dev-python/websockets/websockets-8.1.ebuild [new file with mode: 0644]

diff --git a/dev-python/websockets/Manifest b/dev-python/websockets/Manifest
new file mode 100644 (file)
index 0000000..f9723eb
--- /dev/null
@@ -0,0 +1 @@
+DIST websockets-8.1.tar.gz 58874 BLAKE2B 4f0541fdf5ebaa6199d9911e67279cbbe3937f8ac8f31f2579a35a9a5a7c468f925d20686bc47c6544b6c296f3d51e13e63edfdd199040ad00eb813905fbf70d SHA512 408e35d7a908830d51b3b9b73a1c34b1b2dbabbbbd2431515bc0fba7f6ec7db402a55fd00dc737d344549fd5d5f2d90e27cef7cd5f7847e4a1545d3c74db007c
diff --git a/dev-python/websockets/metadata.xml b/dev-python/websockets/metadata.xml
new file mode 100644 (file)
index 0000000..a3e9378
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>games@gentoo.org</email>
+               <name>Gentoo Games Project</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">aaugustin/websockets</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/websockets/websockets-8.1.ebuild b/dev-python/websockets/websockets-8.1.ebuild
new file mode 100644 (file)
index 0000000..4bc08ce
--- /dev/null
@@ -0,0 +1,16 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for building WebSocket servers and clients in Python"
+HOMEPAGE="https://websockets.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"