media-libs/mesa: Require LLVM 3.9.0+
authorMichał Górny <mgorny@gentoo.org>
Sun, 17 Sep 2017 09:05:51 +0000 (11:05 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 28 Sep 2017 13:15:12 +0000 (15:15 +0200)
Now that LLVM 3.9 is stable, the older versions are on the cleanup list
and there is really no reason to create overcomplex dependencies
to account for them. Furthermore, according to configure.ac all of
the Radeon drivers & swrast require 3.9 anyway.

media-libs/mesa/mesa-9999.ebuild

index 4aef2f2d5a80d55fa0577cc06b83e683b341174d..495b5a5e0b6156ec78750eff41877104ee9edfae 100644 (file)
@@ -143,22 +143,16 @@ RDEPEND="${RDEPEND}
 RDEPEND="${RDEPEND}
        llvm? (
                video_cards_radeonsi? (
-                       vulkan? ( >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}] )
-                       || (
-                               sys-devel/llvm[llvm_targets_AMDGPU]
-                               sys-devel/llvm[video_cards_radeon]
-                       )
+                       >=sys-devel/llvm-3.9.0[llvm_targets_AMDGPU(-)]
                )
-               >=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
+               >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}]
        )
        opencl? (
-               >=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
-               >=sys-devel/clang-3.6.0:=[${MULTILIB_USEDEP}]
+               >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}]
+               >=sys-devel/clang-3.9.0:=[${MULTILIB_USEDEP}]
        )
 "
 
-# FIXME: kill the sys-devel/llvm[video_cards_radeon] compat once
-# LLVM < 3.9 is out of the game
 DEPEND="${RDEPEND}
        ${PYTHON_DEPS}
        opencl? (