dev-python/flake8: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 08:56:06 +0000 (09:56 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 08:58:14 +0000 (09:58 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/flake8/Manifest
dev-python/flake8/flake8-3.5.0.ebuild [deleted file]

index 5432131e6a910b8caf7f8721d11891b4aaee53b5..eb339487dbfbf5c1731e6214fc4ff68977d1052b 100644 (file)
@@ -1,2 +1 @@
-DIST flake8-3.5.0.tar.gz 140608 BLAKE2B 938ad4406370da27155512355432edd23a824db1d6ee635591628fefad43ee1116256ae7f240496d93941800212ea2479be73fb9ee9bd03c9a54ab70bbce452f SHA512 ac5d1bd9c44ed76c9e5cbd941b24bb552aa76e156b24ccda6cc8440ee90f3a574fdb393665adc75298e4f57111d7ab3115ef21ef9088fb327d0a9703d442450c
 DIST flake8-3.7.9.tar.gz 150123 BLAKE2B fd46710c0dcce7d3dcb3d5fc8ff7a83a35315679fa838e68abafd5bdc342c13218706fec0dac3fc9a6d919971f1f846c855f00cbd60c925e979378e431dace0b SHA512 c3c753ad050d8a8f87f7c28c8a1c953ed9bd04f08b09512d9323152b4eebb57d67fbfb0f5317d629174fa12fa234e1a86d6a633dd951fff6a45330b1c4f62850
diff --git a/dev-python/flake8/flake8-3.5.0.ebuild b/dev-python/flake8/flake8-3.5.0.ebuild
deleted file mode 100644 (file)
index 331d5d6..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="https://gitlab.com/pycqa/flake8 https://pypi.org/project/flake8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# requires.txt inc. mccabe however that creates a circular dep
-RDEPEND="
-       >=dev-python/pyflakes-1.5.0[${PYTHON_USEDEP}]
-       <dev-python/pyflakes-1.7.0[${PYTHON_USEDEP}]
-       >=dev-python/pycodestyle-2.0.0[${PYTHON_USEDEP}]
-       <dev-python/pycodestyle-2.4.0[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '
-               dev-python/configparser[${PYTHON_USEDEP}]
-               dev-python/enum34[${PYTHON_USEDEP}]
-       ' -2)
-"
-PDEPEND="
-       >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
-       <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               ${PDEPEND}
-               dev-python/pytest[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-       )
-"
-
-python_prepare_all() {
-       # Flake8 falsely assumes it needs pytest-runner unconditionally and will
-       # try to install it, causing sandbox violations.
-       sed -i -e "/setup_requires=\['pytest-runner'\],/d" setup.py || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       py.test -v || die "Tests fail with ${EPYTHON}"
-}