sci-electronics/gazebo: Bump to 6.1.0.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 16 Sep 2015 13:16:52 +0000 (15:16 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 16 Sep 2015 13:17:11 +0000 (15:17 +0200)
Package-Manager: portage-2.2.20.1

sci-electronics/gazebo/Manifest
sci-electronics/gazebo/gazebo-6.1.0.ebuild [new file with mode: 0644]

index 260d3567496c16b0b93848abb320f41061fe8863..7bfa15f0f8479f07e7e1df8595aa4e2f3b337ecd 100644 (file)
@@ -1 +1,2 @@
+DIST gazebo-6.1.0.tar.bz2 50795925 SHA256 0460f1c706f609b6ff0e61a71bdd3cac2d55d714147edc01609b5226e7fb2904 SHA512 ae41b53b0f33e81fe5b3baaaca8649e98c5b99c4701650414b0686f9a327d89e00c674e806cb9537aabfd933c9819d668e45b18e964d383d99325c5ddcdcf7ef WHIRLPOOL bfab23edc9c68ca02aefa4a20206bfdf2973cc5ee7750f4c017543979dca10434d9e38dad8836510b292dc67b97aa0514229c8b5fd9f73897075525e45a5bd74
 DIST gazebo5_5.1.0.tar.bz2 49544340 SHA256 eac72ca2633deb7ea0f5e775c1208f0743d98c8b53083607df77bae6e38ab0b1 SHA512 d3222d9d98cc9d1c52bc1bb24e12ece7ff8d8506782f9cd2d574a1aca8556e33d93781f4d2c91eacfe317a35c7cddfa2c4a4fdb58da1f348142f6a887de3c981 WHIRLPOOL 5e9e01195b02581d684ee0c5e30f9ace0210a7b61a59a63b7a3c01c8c672230ad026f998ed93583eafb9b640c73c9df350e578a774d9579fdb8574570fa0bd94
diff --git a/sci-electronics/gazebo/gazebo-6.1.0.ebuild b/sci-electronics/gazebo/gazebo-6.1.0.ebuild
new file mode 100644 (file)
index 0000000..4df9d14
--- /dev/null
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils versionator vcs-snapshot flag-o-matic
+
+DESCRIPTION="A 3D multiple robot simulator with dynamics"
+HOMEPAGE="http://gazebosim.org/"
+SRC_URI="http://osrf-distributions.s3.amazonaws.com/gazebo/releases/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse2 libav test"
+
+RDEPEND="
+       >=dev-libs/protobuf-2.3.0
+       virtual/opengl
+       media-libs/openal
+       net-misc/curl
+       dev-libs/tinyxml
+       dev-libs/libtar
+       dev-cpp/tbb
+       >=dev-games/ogre-1.7.4
+       sci-libs/libccd
+       libav? ( media-video/libav:= )
+       !libav? ( media-video/ffmpeg:= )
+       sci-libs/gts
+       >=sci-physics/bullet-2.82
+       >=dev-libs/sdformat-3.1.0
+       dev-qt/qtcore:4
+       dev-qt/qtgui:4
+       dev-libs/boost:=[threads]
+       sci-libs/gdal
+       virtual/libusb:1
+       dev-libs/libspnav
+       media-libs/freeimage
+       sci-libs/hdf5:=
+       sys-apps/util-linux
+       media-gfx/graphviz
+       sci-libs/ignition-math:2=
+"
+DEPEND="${RDEPEND}
+       dev-qt/qttest:4
+       app-text/ronn
+       virtual/pkgconfig
+       test? ( dev-libs/libxslt )
+"
+CMAKE_BUILD_TYPE=RelWithDebInfo
+PATCHES=(
+       "${FILESDIR}/ffmpeg29.patch"
+)
+
+src_configure() {
+       # doesnt build without it
+       append-cxxflags "-std=c++11"
+       # doesnt build with as-needed either
+       append-ldflags "-Wl,--no-as-needed"
+
+       local mycmakeargs=(
+               "-DUSE_UPSTREAM_CFLAGS=OFF"
+               "-DSSE2_FOUND=$(usex cpu_flags_x86_sse2 TRUE FALSE)"
+               "-DUSE_HOST_CFLAGS=FALSE"
+               "-DENABLE_TESTS_COMPILATION=$(usex test TRUE FALSE)"
+               "-DENABLE_SCREEN_TESTS=FALSE"
+       )
+       cmake-utils_src_configure
+}