projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
df47a12
)
dev-python/psutil: Force -j1
author
Michał Górny
<mgorny@gentoo.org>
Mon, 16 Dec 2019 10:09:56 +0000
(11:09 +0100)
committer
Michał Górny
<mgorny@gentoo.org>
Mon, 16 Dec 2019 10:14:49 +0000
(11:14 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/psutil/psutil-5.6.7.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/psutil/psutil-5.6.7.ebuild
b/dev-python/psutil/psutil-5.6.7.ebuild
index 4d56ce828c32ff2083e0588994466102c5558897..35ea4c888d6f7f97df46fe0e82b80448eb230df6 100644
(file)
--- a/
dev-python/psutil/psutil-5.6.7.ebuild
+++ b/
dev-python/psutil/psutil-5.6.7.ebuild
@@
-39,3
+39,9
@@
python_test() {
TRAVIS=1 APPVEYOR=1 "${EPYTHON}" psutil/tests/__main__.py ||
die "tests failed with ${EPYTHON}"
}
+
+python_compile() {
+ # force -j1 to avoid .o linking race conditions
+ local MAKEOPTS=-j1
+ distutils-r1_python_compile
+}