games-strategy/0ad: version bump to 0.0.18_alpha
authorJulian Ospald <hasufell@gentoo.org>
Fri, 14 Aug 2015 22:47:50 +0000 (00:47 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Fri, 14 Aug 2015 22:47:50 +0000 (00:47 +0200)
games-strategy/0ad/0ad-0.0.18_alpha.ebuild [new file with mode: 0644]
games-strategy/0ad/Manifest
games-strategy/0ad/files/0ad-0.0.18_alpha-gentoo.patch [new file with mode: 0644]

diff --git a/games-strategy/0ad/0ad-0.0.18_alpha.ebuild b/games-strategy/0ad/0ad-0.0.18_alpha.ebuild
new file mode 100644 (file)
index 0000000..258645d
--- /dev/null
@@ -0,0 +1,143 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WX_GTK_VER="2.8"
+
+inherit eutils wxwidgets toolchain-funcs gnome2-utils games
+
+MY_P=0ad-${PV/_/-}
+DESCRIPTION="A free, real-time strategy game"
+HOMEPAGE="http://play0ad.com/"
+SRC_URI="mirror://sourceforge/zero-ad/${MY_P}-unix-build.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="editor +lobby nvtt pch sound test"
+RESTRICT="test"
+
+RDEPEND="
+       dev-libs/boost
+       dev-libs/icu:=
+       dev-libs/libxml2
+       ~games-strategy/0ad-data-${PV}
+       media-libs/libpng:0
+       media-libs/libsdl2[X,opengl,video]
+       net-libs/enet:1.3
+       net-libs/miniupnpc
+       net-misc/curl
+       sys-libs/zlib
+       virtual/jpeg:62
+       virtual/opengl
+       x11-libs/libX11
+       x11-libs/libXcursor
+       editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
+       lobby? ( net-libs/gloox )
+       nvtt? ( media-gfx/nvidia-texture-tools )
+       sound? ( media-libs/libvorbis
+               media-libs/openal )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       test? ( dev-lang/perl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+       epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_configure() {
+       local myconf=(
+               --with-system-nvtt
+               --with-system-miniupnpc
+               --minimal-flags
+               --sdl2
+               $(usex nvtt "" "--without-nvtt")
+               $(usex pch "" "--without-pch")
+               $(usex test "" "--without-tests")
+               $(usex sound "" "--without-audio")
+               $(usex editor "--atlas" "")
+               $(usex lobby "" "--without-lobby")
+               --collada
+               --bindir="${GAMES_BINDIR}"
+               --libdir="$(games_get_libdir)"/${PN}
+               --datadir="${GAMES_DATADIR}"/${PN}
+               )
+
+       # stock premake4 does not work, use the shipped one
+       emake -C "${S}"/build/premake/premake4/build/gmake.unix
+
+       # regenerate scripts.c so our patch applies
+       cd "${S}"/build/premake/premake4 || die
+       "${S}"/build/premake/premake4/bin/release/premake4 embed || die
+
+       # rebuild premake again... this is the most stupid build system
+       emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
+       emake -C "${S}"/build/premake/premake4/build/gmake.unix
+
+       # run premake to create build scripts
+       cd "${S}"/build/premake || die
+       "${S}"/build/premake/premake4/bin/release/premake4 \
+               --file="premake4.lua" \
+               --outpath="../workspaces/gcc/" \
+               --platform=$(usex amd64 "x64" "x32") \
+               --os=linux \
+               "${myconf[@]}" \
+               gmake || die "Premake failed"
+}
+
+src_compile() {
+       tc-export AR
+
+       # build bundled and patched spidermonkey
+       cd libraries/source/spidermonkey || die
+       JOBS="${MAKEOPTS}" ./build.sh || die
+       cd "${S}" || die
+
+       # build 3rd party fcollada
+       emake -C libraries/source/fcollada/src
+
+       # build 0ad
+       emake -C build/workspaces/gcc verbose=1
+}
+
+src_test() {
+       cd binaries/system || die
+       ./test -libdir "${S}/binaries/system" || die "test phase failed"
+}
+
+src_install() {
+       newgamesbin binaries/system/pyrogenesis 0ad
+       use editor && newgamesbin binaries/system/ActorEditor 0ad-ActorEditor
+
+       insinto "${GAMES_DATADIR}"/${PN}
+       doins -r binaries/data/l10n
+
+       exeinto "$(games_get_libdir)"/${PN}
+       doexe binaries/system/libCollada.so
+       doexe libraries/source/spidermonkey/lib/*.so
+       use editor && doexe binaries/system/libAtlasUI.so
+
+       dodoc binaries/system/readme.txt
+       doicon -s 128 build/resources/${PN}.png
+       make_desktop_entry ${PN}
+
+       prepgamesdirs
+}
+
+pkg_preinst() {
+       games_pkg_preinst
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       games_pkg_postinst
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}
index 6ff61256669cb5a24c032c7dc681963e2b973895..ed1863b8f337d2cd200c9bd8b7cdf28fa687f03c 100644 (file)
@@ -1,2 +1,3 @@
 DIST 0ad-0.0.16-alpha-unix-build.tar.xz 20019680 SHA256 cb965ef7e292bc3a2f1f598a9695e16ff4d786398f384a1ec7d5f9bfe2626de5 SHA512 9fe3440233d9827895b91ade1873afe977d62386a5dd6042d8169b153d576b462381bfc97e637f0b183aff034236380ca6d552ea2755cf08398143ad67121031 WHIRLPOOL 0e2f1ac9799a4b4d4588c2370a78195f2cc415fb2043be815ed2a2f9f179ccd856c405e7c0323f2033d3a6a4d63c08d8d5c8a05b50769ae3b9219717218edef6
 DIST 0ad-0.0.17-alpha-unix-build.tar.xz 19327284 SHA256 ef144d44fe8a8abd29a4642999a58a596b8f0d0e1f310065f5ce1dfbe29c3aeb SHA512 21133b7f255df73909e0ba72d455ed8d687cdca4a6d28fb04fb2a786ee941d7f4e207b5c245f9bfff1f3e5e10e2ccc932f49587e227982885eef64b4114d02c6 WHIRLPOOL 662e177293ca7add73ca160b67a526aeda6a7a32e26a68fb577376d25db00df9844fe763a2dfcef70f66fc0edd6d2297158251a517deeaa7d7e8292850a8b444
+DIST 0ad-0.0.18-alpha-unix-build.tar.xz 26179952 SHA256 bd2f04d3269ae9af104626827446a89ea4a0dd4859f89539701fd331cbae0397 SHA512 f332780d38e3fc2665a5952ae9cd25ab89508b3b27d810cf1b386d6c6d636aeed306135c37baf6232ba8c0d0e7923ecb0b4fc127a6de5ce1248dfc38158e0c41 WHIRLPOOL 82af33e3ece02885c97c364838de7ff1efb200ca021c94db40dbd0ef877ee07a96dc6a200113e9b459fa441c8168f863d6f6a10bceb7f00a1bc0511b367621c8
diff --git a/games-strategy/0ad/files/0ad-0.0.18_alpha-gentoo.patch b/games-strategy/0ad/files/0ad-0.0.18_alpha-gentoo.patch
new file mode 100644 (file)
index 0000000..5c48ec8
--- /dev/null
@@ -0,0 +1,101 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sun Jun 24 18:32:38 UTC 2012
+Subject: build system
+
+* respect flags
+* disable debug build of spidermonkey
+
+--- libraries/source/fcollada/src/Makefile
++++ libraries/source/fcollada/src/Makefile
+@@ -9,9 +9,9 @@
+ CXX ?= g++
+ CXXFLAGS += -fvisibility=hidden -W -Wall -Wno-unused-parameter -Wno-unused-function $(OS_DEFINE) $(PIC_FLAGS) $(CPPFLAGS)
+-CXXFLAGS_DEBUG := -O0 -g -D_DEBUG -DRETAIL
+-CXXFLAGS_RELEASE := -O2 -DNDEBUG -DRETAIL
+-CXXFLAGS_TEST := -O0 -g -D_DEBUG
++CXXFLAGS_DEBUG := -D_DEBUG -DRETAIL
++CXXFLAGS_RELEASE := -DNDEBUG -DRETAIL
++CXXFLAGS_TEST := -D_DEBUG
+ LIBS += `pkg-config libxml-2.0 --libs`
+ INCLUDES += -IFCollada `pkg-config libxml-2.0 --cflags`
+ INCLUDES_TEST := -IFCollada/FColladaTest $(INCLUDES)
+--- build/premake/premake4/src/tools/gcc.lua
++++ build/premake/premake4/src/tools/gcc.lua
+@@ -136,8 +136,6 @@
+               if not cfg.flags.Symbols then
+                       if cfg.system == "macosx" then
+                               table.insert(result, "-Wl,-x")
+-                      else
+-                              table.insert(result, "-s")
+                       end
+               end
+       
+--- build/premake/premake4/build/gmake.unix/Premake4.make
++++ build/premake/premake4/build/gmake.unix/Premake4.make
+@@ -26,9 +26,9 @@
+   DEFINES   += -DNDEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
+   INCLUDES  += -I../../src/host/lua-5.1.4/src
+   CPPFLAGS  += -MMD -MP $(DEFINES) $(INCLUDES)
+-  CFLAGS    += $(CPPFLAGS) -Wall -Os
+-  CXXFLAGS  += $(CPPFLAGS) -Wall -Os
+-  LDFLAGS   += -s -rdynamic
++  CFLAGS    += $(CPPFLAGS) -Wall
++  CXXFLAGS  += $(CPPFLAGS) -Wall
++  LDFLAGS   += -rdynamic
+   LIBS      += -lm -ldl 
+   RESFLAGS  += $(DEFINES) $(INCLUDES) 
+   LDDEPS    += 
+@@ -48,8 +48,8 @@
+   DEFINES   += -D_DEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
+   INCLUDES  += -I../../src/host/lua-5.1.4/src
+   CPPFLAGS  += -MMD -MP $(DEFINES) $(INCLUDES)
+-  CFLAGS    += $(CPPFLAGS) -Wall -g
+-  CXXFLAGS  += $(CPPFLAGS) -Wall -g
++  CFLAGS    += $(CPPFLAGS) -Wall
++  CXXFLAGS  += $(CPPFLAGS) -Wall
+   LDFLAGS   += -rdynamic
+   LIBS      += -lm -ldl 
+   RESFLAGS  += $(DEFINES) $(INCLUDES) 
+@@ -302,4 +302,4 @@
+       $(SILENT) $(CC) $(PCHINCLUDES) $(CFLAGS) -MF $(OBJDIR)/lauxlib.d -MT "$@" -o "$@" -c "$<"\r
\r
+ -include $(OBJECTS:%.o=%.d)\r
+--include $(GCH:%.h.gch=%.h.d)
+\ No newline at end of file
++-include $(GCH:%.h.gch=%.h.d)
+--- libraries/source/spidermonkey/build.sh
++++ libraries/source/spidermonkey/build.sh
+@@ -92,19 +92,7 @@
+ cd mozjs31/js/src
+ # Clean up data generated by previous builds that could cause problems
+-rm -rf build-debug
+ rm -rf build-release
+-
+-# We want separate debug/release versions of the library, so we have to change
+-# the LIBRARY_NAME for each build.
+-# (We use perl instead of sed so that it works with MozillaBuild on Windows,
+-# which has an ancient sed.)
+-perl -i.bak -pe 's/(LIBRARY_NAME\s+=).*/$1 '\''mozjs31-ps-debug'\''/' moz.build
+-mkdir -p build-debug
+-cd build-debug
+-CXXFLAGS="${TLCXXFLAGS}" ../configure ${CONF_OPTS} --with-nspr-libs="$NSPR_LIBS" --with-nspr-cflags="$NSPR_INCLUDES" --enable-debug --disable-optimize --enable-js-diagnostics --enable-gczeal # --enable-root-analysis
+-${MAKE} ${MAKE_OPTS}
+-cd ..
+ perl -i.bak -pe 's/(LIBRARY_NAME\s+=).*/$1 '\''mozjs31-ps-release'\''/' moz.build
+ mkdir -p build-release
+@@ -147,12 +135,9 @@
+ mkdir -p ${INCLUDE_DIR_DEBUG}
+ mkdir -p ${INCLUDE_DIR_RELEASE}
+ cp -R -L mozjs31/js/src/build-release/dist/include/* ${INCLUDE_DIR_RELEASE}/
+-cp -R -L mozjs31/js/src/build-debug/dist/include/* ${INCLUDE_DIR_DEBUG}/
+ mkdir -p lib/
+-cp -L mozjs31/js/src/build-debug/dist/lib/${LIB_PREFIX}mozjs31-ps-debug${LIB_SRC_SUFFIX} lib/${LIB_PREFIX}mozjs31-ps-debug${LIB_DST_SUFFIX}
+ cp -L mozjs31/js/src/build-release/dist/lib/${LIB_PREFIX}mozjs31-ps-release${LIB_SRC_SUFFIX} lib/${LIB_PREFIX}mozjs31-ps-release${LIB_DST_SUFFIX}
+-cp -L mozjs31/js/src/build-debug/dist/bin/${LIB_PREFIX}mozjs31-ps-debug${DLL_SRC_SUFFIX} ../../../binaries/system/${LIB_PREFIX}mozjs31-ps-debug${DLL_DST_SUFFIX}
+ cp -L mozjs31/js/src/build-release/dist/bin/${LIB_PREFIX}mozjs31-ps-release${DLL_SRC_SUFFIX} ../../../binaries/system/${LIB_PREFIX}mozjs31-ps-release${DLL_DST_SUFFIX}
+ # Flag that it's already been built successfully so we can skip it next time