sys-devel/llvm: Revert upstream AMDGPU breakage, #603858
authorMichał Górny <mgorny@gentoo.org>
Sat, 21 Jan 2017 11:37:46 +0000 (12:37 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 21 Jan 2017 13:03:43 +0000 (14:03 +0100)
sys-devel/llvm/files/3.9.1/0009-Revert-AMDGPU-Fix-an-interaction-between-WQM-and-pol.patch [new file with mode: 0644]
sys-devel/llvm/llvm-3.9.1-r1.ebuild [new file with mode: 0644]

diff --git a/sys-devel/llvm/files/3.9.1/0009-Revert-AMDGPU-Fix-an-interaction-between-WQM-and-pol.patch b/sys-devel/llvm/files/3.9.1/0009-Revert-AMDGPU-Fix-an-interaction-between-WQM-and-pol.patch
new file mode 100644 (file)
index 0000000..f9ec68c
--- /dev/null
@@ -0,0 +1,120 @@
+From d6b5bd6f44e8091a4c4870f1c52921c25a4f8cca Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 21 Jan 2017 12:35:36 +0100
+Subject: [PATCH] Revert "AMDGPU: Fix an interaction between WQM and polygon
+ stippling"
+
+https://bugs.gentoo.org/603858
+---
+ lib/Target/AMDGPU/SIInstructions.td   |  1 -
+ lib/Target/AMDGPU/SIWholeQuadMode.cpp |  7 +++++
+ test/CodeGen/AMDGPU/wqm.ll            | 49 +++--------------------------------
+ 3 files changed, 11 insertions(+), 46 deletions(-)
+
+diff --git a/lib/Target/AMDGPU/SIInstructions.td b/lib/Target/AMDGPU/SIInstructions.td
+index dde5f2fc6b4..18b7d5d62ef 100644
+--- a/lib/Target/AMDGPU/SIInstructions.td
++++ b/lib/Target/AMDGPU/SIInstructions.td
+@@ -2029,7 +2029,6 @@ def SI_RETURN : PseudoInstSI <
+   let hasSideEffects = 1;
+   let SALU = 1;
+   let hasNoSchedulingInfo = 1;
+-  let DisableWQM = 1;
+ }
+ let Uses = [EXEC], Defs = [EXEC, VCC, M0],
+diff --git a/lib/Target/AMDGPU/SIWholeQuadMode.cpp b/lib/Target/AMDGPU/SIWholeQuadMode.cpp
+index 1534d582569..b200c153df0 100644
+--- a/lib/Target/AMDGPU/SIWholeQuadMode.cpp
++++ b/lib/Target/AMDGPU/SIWholeQuadMode.cpp
+@@ -219,6 +219,13 @@ char SIWholeQuadMode::scanInstructions(MachineFunction &MF,
+       markInstruction(MI, Flags, Worklist);
+       GlobalFlags |= Flags;
+     }
++
++    if (WQMOutputs && MBB.succ_empty()) {
++      // This is a prolog shader. Make sure we go back to exact mode at the end.
++      Blocks[&MBB].OutNeeds = StateExact;
++      Worklist.push_back(&MBB);
++      GlobalFlags |= StateExact;
++    }
+   }
+   return GlobalFlags;
+diff --git a/test/CodeGen/AMDGPU/wqm.ll b/test/CodeGen/AMDGPU/wqm.ll
+index 41e42645788..809a7ba9b82 100644
+--- a/test/CodeGen/AMDGPU/wqm.ll
++++ b/test/CodeGen/AMDGPU/wqm.ll
+@@ -17,18 +17,17 @@ main_body:
+ ;CHECK-LABEL: {{^}}test2:
+ ;CHECK-NEXT: ; %main_body
+ ;CHECK-NEXT: s_wqm_b64 exec, exec
++;CHECK: image_sample
+ ;CHECK-NOT: exec
+-define amdgpu_ps void @test2(<8 x i32> inreg %rsrc, <4 x i32> inreg %sampler, float addrspace(1)* inreg %ptr, <4 x i32> %c) {
++;CHECK: _load_dword v0,
++define amdgpu_ps float @test2(<8 x i32> inreg %rsrc, <4 x i32> inreg %sampler, float addrspace(1)* inreg %ptr, <4 x i32> %c) {
+ main_body:
+   %c.1 = call <4 x float> @llvm.SI.image.sample.v4i32(<4 x i32> %c, <8 x i32> %rsrc, <4 x i32> %sampler, i32 15, i32 0, i32 0, i32 0, i32 0, i32 0, i32 0, i32 0)
+   %c.2 = bitcast <4 x float> %c.1 to <4 x i32>
+   %c.3 = extractelement <4 x i32> %c.2, i32 0
+   %gep = getelementptr float, float addrspace(1)* %ptr, i32 %c.3
+   %data = load float, float addrspace(1)* %gep
+-
+-  call void @llvm.SI.export(i32 15, i32 1, i32 1, i32 0, i32 1, float %data, float undef, float undef, float undef)
+-
+-  ret void
++  ret float %data
+ }
+ ; ... but disabled for stores (and, in this simple case, not re-enabled).
+@@ -415,46 +414,6 @@ entry:
+   ret void
+ }
+-; Must return to exact at the end of a non-void returning shader,
+-; otherwise the EXEC mask exported by the epilog will be wrong. This is true
+-; even if the shader has no kills, because a kill could have happened in a
+-; previous shader fragment.
+-;
+-; CHECK-LABEL: {{^}}test_nonvoid_return:
+-; CHECK: s_mov_b64 [[LIVE:s\[[0-9]+:[0-9]+\]]], exec
+-; CHECK: s_wqm_b64 exec, exec
+-;
+-; CHECK: s_and_b64 exec, exec, [[LIVE]]
+-; CHECK-NOT: exec
+-define amdgpu_ps <4 x float> @test_nonvoid_return() nounwind {
+-  %tex = call <4 x float> @llvm.SI.image.sample.v4i32(<4 x i32> undef, <8 x i32> undef, <4 x i32> undef, i32 15, i32 0, i32 0, i32 0, i32 0, i32 0, i32 0, i32 0)
+-  %tex.i = bitcast <4 x float> %tex to <4 x i32>
+-  %dtex = call <4 x float> @llvm.SI.image.sample.v4i32(<4 x i32> %tex.i, <8 x i32> undef, <4 x i32> undef, i32 15, i32 0, i32 0, i32 0, i32 0, i32 0, i32 0, i32 0)
+-  ret <4 x float> %dtex
+-}
+-
+-; CHECK-LABEL: {{^}}test_nonvoid_return_unreachable:
+-; CHECK: s_mov_b64 [[LIVE:s\[[0-9]+:[0-9]+\]]], exec
+-; CHECK: s_wqm_b64 exec, exec
+-;
+-; CHECK: s_and_b64 exec, exec, [[LIVE]]
+-; CHECK-NOT: exec
+-define amdgpu_ps <4 x float> @test_nonvoid_return_unreachable(i32 inreg %c) nounwind {
+-entry:
+-  %tex = call <4 x float> @llvm.SI.image.sample.v4i32(<4 x i32> undef, <8 x i32> undef, <4 x i32> undef, i32 15, i32 0, i32 0, i32 0, i32 0, i32 0, i32 0, i32 0)
+-  %tex.i = bitcast <4 x float> %tex to <4 x i32>
+-  %dtex = call <4 x float> @llvm.SI.image.sample.v4i32(<4 x i32> %tex.i, <8 x i32> undef, <4 x i32> undef, i32 15, i32 0, i32 0, i32 0, i32 0, i32 0, i32 0, i32 0)
+-
+-  %cc = icmp sgt i32 %c, 0
+-  br i1 %cc, label %if, label %else
+-
+-if:
+-  store volatile <4 x float> %dtex, <4 x float>* undef
+-  unreachable
+-
+-else:
+-  ret <4 x float> %dtex
+-}
+ declare void @llvm.amdgcn.image.store.v4i32(<4 x float>, <4 x i32>, <8 x i32>, i32, i1, i1, i1, i1) #1
+ declare void @llvm.amdgcn.buffer.store.f32(float, <4 x i32>, i32, i32, i1, i1) #1
+-- 
+2.11.0
+
diff --git a/sys-devel/llvm/llvm-3.9.1-r1.ebuild b/sys-devel/llvm/llvm-3.9.1-r1.ebuild
new file mode 100644 (file)
index 0000000..20bee28
--- /dev/null
@@ -0,0 +1,551 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+# (needed due to lib32 find_library fix)
+CMAKE_MIN_VERSION=3.6.1-r1
+PYTHON_COMPAT=( python2_7 )
+
+inherit check-reqs cmake-utils eutils flag-o-matic multilib \
+       multilib-minimal python-single-r1 toolchain-funcs pax-utils prefix
+
+DESCRIPTION="Low Level Virtual Machine"
+HOMEPAGE="http://llvm.org/"
+SRC_URI="http://llvm.org/releases/${PV}/${P}.src.tar.xz
+       clang? ( http://llvm.org/releases/${PV}/compiler-rt-${PV}.src.tar.xz
+               http://llvm.org/releases/${PV}/cfe-${PV}.src.tar.xz
+               http://llvm.org/releases/${PV}/clang-tools-extra-${PV}.src.tar.xz )
+       lldb? ( http://llvm.org/releases/${PV}/lldb-${PV}.src.tar.xz )
+       !doc? ( http://dev.gentoo.org/~mgorny/dist/${PN}-3.9.0_rc3-manpages.tar.bz2 )"
+
+# Keep in sync with CMakeLists.txt
+ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Mips MSP430
+       NVPTX PowerPC Sparc SystemZ X86 XCore )
+ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
+
+# Additional licenses:
+# 1. OpenBSD regex: Henry Spencer's license ('rc' in Gentoo) + BSD.
+# 2. ARM backend: LLVM Software Grant by ARM.
+# 3. MD5 code: public-domain.
+# 4. Tests (not installed):
+#  a. gtest: BSD.
+#  b. YAML tests: MIT.
+
+LICENSE="UoI-NCSA rc BSD public-domain
+       llvm_targets_ARM? ( LLVM-Grant )"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="clang debug default-compiler-rt default-libcxx doc gold libedit +libffi
+       lldb multitarget ncurses ocaml python +sanitize +static-analyzer test xml
+       elibc_musl kernel_Darwin kernel_FreeBSD ${ALL_LLVM_TARGETS[*]}"
+
+COMMON_DEPEND="
+       sys-libs/zlib:0=
+       clang? (
+               python? ( ${PYTHON_DEPS} )
+               static-analyzer? (
+                       dev-lang/perl:*
+                       ${PYTHON_DEPS}
+               )
+               xml? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
+       )
+       gold? ( >=sys-devel/binutils-2.22:*[cxx] )
+       libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
+       libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
+       lldb? ( dev-python/six[${PYTHON_USEDEP}] )
+       ncurses? ( >=sys-libs/ncurses-5.9-r3:0=[${MULTILIB_USEDEP}] )
+       ocaml? (
+               >=dev-lang/ocaml-4.00.0:0=
+               dev-ml/ocaml-ctypes:=
+               !!<=sys-devel/llvm-3.7.0-r1[ocaml] )"
+# configparser-3.2 breaks the build (3.3 or none at all are fine)
+DEPEND="${COMMON_DEPEND}
+       dev-lang/perl
+       >=sys-devel/make-3.81
+       >=sys-devel/flex-2.5.4
+       >=sys-devel/bison-1.875d
+       || ( >=sys-devel/gcc-3.0 >=sys-devel/llvm-3.5
+               ( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
+       )
+       || ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
+       kernel_Darwin? ( <sys-libs/libcxx-${PV%_rc*}.9999 )
+       clang? ( xml? ( virtual/pkgconfig ) )
+       doc? ( dev-python/sphinx )
+       gold? ( sys-libs/binutils-libs )
+       libffi? ( virtual/pkgconfig )
+       lldb? ( dev-lang/swig )
+       !!<dev-python/configparser-3.3.0.2
+       ocaml? ( dev-ml/findlib
+               test? ( dev-ml/ounit ) )
+       ${PYTHON_DEPS}"
+RDEPEND="${COMMON_DEPEND}
+       clang? ( !<=sys-devel/clang-${PV}-r99 )
+       abi_x86_32? ( !<=app-emulation/emul-linux-x86-baselibs-20130224-r2
+               !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] )"
+PDEPEND="
+       clang? (
+               =sys-devel/clang-${PV}-r100
+               ~sys-devel/clang-runtime-${PV}
+       )
+       default-libcxx? ( sys-libs/libcxx )
+       kernel_Darwin? ( =sys-libs/libcxx-${PV%.*}* )"
+
+# pypy gives me around 1700 unresolved tests due to open file limit
+# being exceeded. probably GC does not close them fast enough.
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+       lldb? ( clang xml )
+       || ( ${ALL_LLVM_TARGETS[*]} )
+       multitarget? ( ${ALL_LLVM_TARGETS[*]} )"
+
+S=${WORKDIR}/${P/_}.src
+
+check_space() {
+       # in megs
+       # !clang !debug !multitarget -O2       400
+       # !clang !debug  multitarget -O2       550
+       #  clang !debug !multitarget -O2       950
+       #  clang !debug  multitarget -O2      1200
+       # !clang  debug  multitarget -O2      5G
+       #  clang !debug  multitarget -O0 -g  12G
+       #  clang  debug  multitarget -O2     16G
+       #  clang  debug  multitarget -O0 -g  14G
+
+       local build_size=550
+       use clang && build_size=1200
+
+       if use debug; then
+               ewarn "USE=debug is known to increase the size of package considerably"
+               ewarn "and cause the tests to fail."
+               ewarn
+
+               (( build_size *= 14 ))
+       elif is-flagq '-g?(gdb)?([1-9])'; then
+               ewarn "The C++ compiler -g option is known to increase the size of the package"
+               ewarn "considerably. If you run out of space, please consider removing it."
+               ewarn
+
+               (( build_size *= 10 ))
+       fi
+
+       # Multiply by number of ABIs :).
+       local abis=( $(multilib_get_enabled_abis) )
+       (( build_size *= ${#abis[@]} ))
+
+       local CHECKREQS_DISK_BUILD=${build_size}M
+       check-reqs_pkg_pretend
+}
+
+pkg_pretend() {
+       check_space
+}
+
+pkg_setup() {
+       check_space
+}
+
+src_unpack() {
+       default
+
+       if use clang; then
+               mv "${WORKDIR}"/cfe-${PV/_}.src "${S}"/tools/clang \
+                       || die "clang source directory move failed"
+               mv "${WORKDIR}"/compiler-rt-${PV/_}.src "${S}"/projects/compiler-rt \
+                       || die "compiler-rt source directory move failed"
+               mv "${WORKDIR}"/clang-tools-extra-${PV/_}.src "${S}"/tools/clang/tools/extra \
+                       || die "clang-tools-extra source directory move failed"
+       fi
+
+       if use lldb; then
+               mv "${WORKDIR}"/lldb-${PV/_}.src "${S}"/tools/lldb \
+                       || die "lldb source directory move failed"
+       fi
+}
+
+src_prepare() {
+       python_setup
+
+       # Fix libdir for ocaml bindings install, bug #559134
+       eapply "${FILESDIR}"/3.9.1/0001-cmake-Install-OCaml-modules-into-correct-package-loc.patch
+       # Do not build/install ocaml docs with USE=-doc, bug #562008
+       eapply "${FILESDIR}"/3.9.1/0002-cmake-Make-OCaml-docs-dependent-on-LLVM_BUILD_DOCS.patch
+
+       # Make it possible to override Sphinx HTML install dirs
+       # https://llvm.org/bugs/show_bug.cgi?id=23780
+       eapply "${FILESDIR}"/3.9.1/0003-cmake-Support-overriding-Sphinx-HTML-doc-install-dir.patch
+
+       # Prevent race conditions with parallel Sphinx runs
+       # https://llvm.org/bugs/show_bug.cgi?id=23781
+       eapply "${FILESDIR}"/3.9.1/0004-cmake-Add-an-ordering-dep-between-HTML-man-Sphinx-ta.patch
+
+       # Allow custom cmake build types (like 'Gentoo')
+       eapply "${FILESDIR}"/3.9.1/0006-cmake-Remove-the-CMAKE_BUILD_TYPE-assertion.patch
+
+       # Fix llvm-config for shared linking and sane flags
+       # https://bugs.gentoo.org/show_bug.cgi?id=565358
+       eapply "${FILESDIR}"/3.9.1/llvm-config-r1.patch
+
+       # Restore SOVERSIONs for shared libraries
+       # https://bugs.gentoo.org/show_bug.cgi?id=578392
+       eapply "${FILESDIR}"/3.9.1/0008-cmake-Reintroduce-ldconfig-compatible-SOVERSIONs-on-.patch
+
+       # Revert commit breaking AMDGPU
+       # https://bugs.gentoo.org/show_bug.cgi?id=603858
+       eapply "${FILESDIR}"/3.9.1/0009-Revert-AMDGPU-Fix-an-interaction-between-WQM-and-pol.patch
+
+       # support building llvm against musl-libc
+       use elibc_musl && eapply "${FILESDIR}"/9999/musl-fixes.patch
+
+       # disable use of SDK on OSX, bug #568758
+       sed -i -e 's/xcrun/false/' utils/lit/lit/util.py || die
+
+       # Workaround, can be compiled with gcc on Gentoo/FreeBSD, bug #578064
+       use kernel_FreeBSD && tc-is-gcc && append-cppflags "-D_GLIBCXX_USE_C99"
+
+       if use clang; then
+               # Automatically select active system GCC's libraries, bugs #406163 and #417913
+               eapply "${FILESDIR}"/3.9.1/clang/gcc-config.patch
+
+               eapply "${FILESDIR}"/3.9.1/clang/darwin_prefix-include-paths.patch
+               eprefixify tools/clang/lib/Frontend/InitHeaderSearch.cpp
+
+               eapply "${FILESDIR}"/3.8.1/compiler-rt/darwin-default-sysroot.patch
+
+               pushd "${S}"/tools/clang >/dev/null || die
+               # be able to specify default values for -stdlib and -rtlib at build time
+               eapply "${FILESDIR}"/3.9.1/clang/default-libs.patch
+               popd >/dev/null || die
+
+               sed -i -e "s^@EPREFIX@^${EPREFIX}^" \
+                       tools/clang/tools/scan-build/bin/scan-build || die
+
+               # Install clang runtime into /usr/lib/clang
+               # https://llvm.org/bugs/show_bug.cgi?id=23792
+               eapply "${FILESDIR}"/3.9.1/clang/0001-Install-clang-runtime-into-usr-lib-without-suffix.patch
+               eapply "${FILESDIR}"/3.9.1/compiler-rt/0001-cmake-Install-compiler-rt-into-usr-lib-without-suffi.patch
+
+               # Make it possible to override CLANG_LIBDIR_SUFFIX
+               # (that is used only to find LLVMgold.so)
+               # https://llvm.org/bugs/show_bug.cgi?id=23793
+               eapply "${FILESDIR}"/3.9.1/clang/0002-cmake-Make-CLANG_LIBDIR_SUFFIX-overridable.patch
+
+               # Fix git-clang-format shebang, bug #562688
+               python_fix_shebang tools/clang/tools/clang-format/git-clang-format
+
+               pushd projects/compiler-rt >/dev/null || die
+
+               # Fix WX sections, bug #421527
+               find lib/builtins -type f -name '*.S' -exec sed \
+                       -e '$a\\n#if defined(__linux__) && defined(__ELF__)\n.section .note.GNU-stack,"",%progbits\n#endif' \
+                       -i {} + || die
+
+               popd >/dev/null || die
+       fi
+
+       if use lldb; then
+               # Do not install dummy readline.so module from
+               # https://llvm.org/bugs/show_bug.cgi?id=18841
+               sed -e 's/add_subdirectory(readline)/#&/' \
+                       -i tools/lldb/scripts/Python/modules/CMakeLists.txt || die
+               # Do not install bundled six module
+               eapply "${FILESDIR}"/3.9.1/lldb/six.patch
+       fi
+
+       # User patches
+       eapply_user
+
+       # Native libdir is used to hold LLVMgold.so
+       NATIVE_LIBDIR=$(get_libdir)
+}
+
+multilib_src_configure() {
+       local ffi_cflags ffi_ldflags
+       if use libffi; then
+               ffi_cflags=$($(tc-getPKG_CONFIG) --cflags-only-I libffi)
+               ffi_ldflags=$($(tc-getPKG_CONFIG) --libs-only-L libffi)
+       fi
+
+       local libdir=$(get_libdir)
+       local mycmakeargs=(
+               -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
+
+               -DBUILD_SHARED_LIBS=ON
+               -DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
+               -DLLVM_BUILD_TESTS=$(usex test)
+
+               -DLLVM_ENABLE_FFI=$(usex libffi)
+               -DLLVM_ENABLE_TERMINFO=$(usex ncurses)
+               -DLLVM_ENABLE_ASSERTIONS=$(usex debug)
+               -DLLVM_ENABLE_EH=ON
+               -DLLVM_ENABLE_RTTI=ON
+
+               -DWITH_POLLY=OFF # TODO
+
+               -DLLVM_HOST_TRIPLE="${CHOST}"
+
+               -DFFI_INCLUDE_DIR="${ffi_cflags#-I}"
+               -DFFI_LIBRARY_DIR="${ffi_ldflags#-L}"
+
+               -DHAVE_HISTEDIT_H=$(usex libedit)
+       )
+
+       if use clang; then
+               mycmakeargs+=(
+                       -DCMAKE_DISABLE_FIND_PACKAGE_LibXml2=$(usex !xml)
+                       # libgomp support fails to find headers without explicit -I
+                       # furthermore, it provides only syntax checking
+                       -DCLANG_DEFAULT_OPENMP_RUNTIME=libomp
+
+                       # override default stdlib and rtlib
+                       -DCLANG_DEFAULT_CXX_STDLIB=$(usex default-libcxx libc++ "")
+                       -DCLANG_DEFAULT_RTLIB=$(usex default-compiler-rt compiler-rt "")
+
+                       # compiler-rt's test cases depend on sanitizer
+                       -DCOMPILER_RT_BUILD_SANITIZERS=$(usex sanitize)
+                       -DCOMPILER_RT_INCLUDE_TESTS=$(usex sanitize)
+               )
+       fi
+
+       if use lldb; then
+               mycmakeargs+=(
+                       -DLLDB_DISABLE_LIBEDIT=$(usex !libedit)
+                       -DLLDB_DISABLE_CURSES=$(usex !ncurses)
+                       -DLLDB_ENABLE_TERMINFO=$(usex ncurses)
+               )
+       fi
+
+       if ! multilib_is_native_abi || ! use ocaml; then
+               mycmakeargs+=(
+                       -DOCAMLFIND=NO
+               )
+       fi
+#      Note: go bindings have no CMake rules at the moment
+#      but let's kill the check in case they are introduced
+#      if ! multilib_is_native_abi || ! use go; then
+               mycmakeargs+=(
+                       -DGO_EXECUTABLE=GO_EXECUTABLE-NOTFOUND
+               )
+#      fi
+
+       if multilib_is_native_abi; then
+               mycmakeargs+=(
+                       -DLLVM_BUILD_DOCS=$(usex doc)
+                       -DLLVM_ENABLE_SPHINX=$(usex doc)
+                       -DLLVM_ENABLE_DOXYGEN=OFF
+                       -DLLVM_INSTALL_HTML="${EPREFIX}/usr/share/doc/${PF}/html"
+                       -DSPHINX_WARNINGS_AS_ERRORS=OFF
+                       -DLLVM_INSTALL_UTILS=ON
+               )
+
+               if use clang; then
+                       mycmakeargs+=(
+                               -DCLANG_INSTALL_HTML="${EPREFIX}/usr/share/doc/${PF}/clang"
+                       )
+               fi
+
+               if use gold; then
+                       mycmakeargs+=(
+                               -DLLVM_BINUTILS_INCDIR="${EPREFIX}"/usr/include
+                       )
+               fi
+
+               if use lldb; then
+                       mycmakeargs+=(
+                               -DLLDB_DISABLE_PYTHON=$(usex !python)
+                       )
+               fi
+
+       else
+               if use clang; then
+                       mycmakeargs+=(
+                               # disable compiler-rt on non-native ABI because:
+                               # 1. it fails to configure because of -m32
+                               # 2. it is shared between ABIs so no point building
+                               # it multiple times
+                               -DLLVM_EXTERNAL_COMPILER_RT_BUILD=OFF
+                               -DLLVM_EXTERNAL_CLANG_TOOLS_EXTRA_BUILD=OFF
+                       )
+               fi
+               if use lldb; then
+                       mycmakeargs+=(
+                               # only run swig on native abi
+                               -DLLDB_DISABLE_PYTHON=ON
+                       )
+               fi
+       fi
+
+       if use clang; then
+               mycmakeargs+=(
+                       -DCLANG_ENABLE_ARCMT=$(usex static-analyzer)
+                       -DCLANG_ENABLE_STATIC_ANALYZER=$(usex static-analyzer)
+                       -DCLANG_LIBDIR_SUFFIX="${NATIVE_LIBDIR#lib}"
+               )
+
+               # -- not needed when compiler-rt is built with host compiler --
+               # cmake passes host C*FLAGS to compiler-rt build
+               # which is performed using clang, so we need to filter out
+               # some flags clang does not support
+               # (if you know some more flags that don't work, let us know)
+               #filter-flags -msahf -frecord-gcc-switches
+       fi
+
+       if tc-is-cross-compiler; then
+               [[ -x "/usr/bin/llvm-tblgen" ]] \
+                       || die "/usr/bin/llvm-tblgen not found or usable"
+               mycmakeargs+=(
+                       -DCMAKE_CROSSCOMPILING=ON
+                       -DLLVM_TABLEGEN=/usr/bin/llvm-tblgen
+               )
+
+               if use clang; then
+                       [[ -x "/usr/bin/clang-tblgen" ]] \
+                               || die "/usr/bin/clang-tblgen not found or usable"
+                       mycmakeargs+=(
+                               -DCLANG_TABLEGEN=/usr/bin/clang-tblgen
+                       )
+               fi
+       fi
+
+       cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+       cmake-utils_src_compile
+       # TODO: not sure why this target is not correctly called
+       multilib_is_native_abi && use doc && use ocaml && cmake-utils_src_make docs/ocaml_doc
+
+       pax-mark m "${BUILD_DIR}"/bin/llvm-rtdyld
+       pax-mark m "${BUILD_DIR}"/bin/lli
+       pax-mark m "${BUILD_DIR}"/bin/lli-child-target
+
+       if use test; then
+               pax-mark m "${BUILD_DIR}"/unittests/ExecutionEngine/Orc/OrcJITTests
+               pax-mark m "${BUILD_DIR}"/unittests/ExecutionEngine/MCJIT/MCJITTests
+               pax-mark m "${BUILD_DIR}"/unittests/Support/SupportTests
+       fi
+
+       # provide a symlink for tests
+       if [[ $(get_libdir) != lib ]]; then
+               ln -s "../$(get_libdir)/clang" lib/clang || die
+       fi
+}
+
+multilib_src_test() {
+       # respect TMPDIR!
+       local -x LIT_PRESERVES_TMP=1
+       local test_targets=( check )
+       # clang tests won't work on non-native ABI because we skip compiler-rt
+       multilib_is_native_abi && use clang && test_targets+=( check-clang )
+       cmake-utils_src_make "${test_targets[@]}"
+}
+
+src_install() {
+       local MULTILIB_CHOST_TOOLS=(
+               /usr/bin/llvm-config
+       )
+
+       local MULTILIB_WRAPPED_HEADERS=(
+               /usr/include/llvm/Config/config.h
+               /usr/include/llvm/Config/llvm-config.h
+       )
+
+       if use clang; then
+               MULTILIB_WRAPPED_HEADERS+=(
+                       /usr/include/clang/Config/config.h
+               )
+       fi
+
+       multilib-minimal_src_install
+
+       if use clang; then
+               # Apply CHOST and version suffix to clang tools
+               local clang_version=${PV%.*}
+               local clang_tools=( clang clang++ clang-cl clang-cpp )
+               local abi i
+
+               # cmake gives us:
+               # - clang-X.Y
+               # - clang -> clang-X.Y
+               # - clang++, clang-cl, clang-cpp -> clang
+               # we want to have:
+               # - clang-X.Y
+               # - clang++-X.Y, clang-cl-X.Y, clang-cpp-X.Y -> clang-X.Y
+               # - clang, clang++, clang-cl, clang-cpp -> clang*-X.Y
+               # also in CHOST variant
+               for i in "${clang_tools[@]:1}"; do
+                       rm -f "${ED%/}/usr/bin/${i}" || die
+                       dosym "clang-${clang_version}" "/usr/bin/${i}-${clang_version}"
+                       dosym "${i}-${clang_version}" "/usr/bin/${i}"
+               done
+
+               # now create target symlinks for all supported ABIs
+               for abi in $(get_all_abis); do
+                       local abi_chost=$(get_abi_CHOST "${abi}")
+                       for i in "${clang_tools[@]}"; do
+                               dosym "${i}-${clang_version}" \
+                                       "/usr/bin/${abi_chost}-${i}-${clang_version}"
+                               dosym "${abi_chost}-${i}-${clang_version}" \
+                                       "/usr/bin/${abi_chost}-${i}"
+                       done
+               done
+       fi
+
+       # Remove unnecessary headers on FreeBSD, bug #417171
+       if use kernel_FreeBSD && use clang; then
+               rm "${ED}"usr/lib/clang/${PV}/include/{std,float,iso,limits,tgmath,varargs}*.h || die
+       fi
+}
+
+multilib_src_install() {
+       cmake-utils_src_install
+
+       if multilib_is_native_abi; then
+               # Symlink the gold plugin.
+               if use gold; then
+                       dodir "/usr/${CHOST}/binutils-bin/lib/bfd-plugins"
+                       dosym "../../../../$(get_libdir)/LLVMgold.so" \
+                               "/usr/${CHOST}/binutils-bin/lib/bfd-plugins/LLVMgold.so"
+               fi
+       fi
+}
+
+multilib_src_install_all() {
+       insinto /usr/share/vim/vimfiles
+       doins -r utils/vim/*/.
+       # some users may find it useful
+       dodoc utils/vim/vimrc
+
+       # Install man pages from the prebuilt package
+       if ! use doc; then
+               if ! use clang; then
+                       rm "${WORKDIR}"/${PN}-3.9.0_rc3-manpages/{clang,extraclangtools,scan-build}.1 || die
+               fi
+
+               doman "${WORKDIR}"/${PN}-3.9.0_rc3-manpages/*.1
+       fi
+
+       if use clang; then
+               pushd tools/clang >/dev/null || die
+
+               if use python ; then
+                       pushd bindings/python/clang >/dev/null || die
+
+                       python_moduleinto clang
+                       python_domodule *.py
+
+                       popd >/dev/null || die
+               fi
+
+               # AddressSanitizer symbolizer (currently separate)
+               dobin "${S}"/projects/compiler-rt/lib/asan/scripts/asan_symbolize.py
+
+               popd >/dev/null || die
+
+               python_fix_shebang "${ED}"
+               if use static-analyzer; then
+                       python_optimize "${ED}"usr/share/scan-view
+               fi
+       fi
+}