dev-python/python-magic: Bump to 0.4.18
authorMichał Górny <mgorny@gentoo.org>
Fri, 29 May 2020 06:28:19 +0000 (08:28 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 29 May 2020 07:24:57 +0000 (09:24 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/python-magic/Manifest
dev-python/python-magic/python-magic-0.4.18.ebuild [new file with mode: 0644]

index 516bf228979500351d3098e4cc35068ec95f5f64..9bccdda8f9ea9efed23c6bf73ac1139455735e61 100644 (file)
@@ -1 +1,2 @@
 DIST python-magic-0.4.15.gh.tar.gz 75476 BLAKE2B dad4973f69a21d08972e1e29bc92a51bc92f405907cc28f18eb9357029afdf9f1ba68010ce651acd821140d60dc10eb2e04138627fb19d132f185a2831fcea28 SHA512 004d6bfde52d58a9d3019ef4ff8c5b18b6a4206bf89820d3a0ae0ed78813f80dfba422aee9685528f88c990526ba65fa2153ac3b95b8863ce6cb3ebe925bd780
+DIST python-magic-0.4.18.gh.tar.gz 856291 BLAKE2B 882c86d3e8995d1e1b6168637a01f4f8bc86f23390b1c67248baf46d16d574a41789938ccdf0acd83db0652678ab0fa0f6e043eb2c4a75743e5d448e80530da5 SHA512 d5f0047c7537ce0598537629c60aa708623480792d489fa003328b5c6c5b0d42748b6e996f27dc2c164c598813fcf19393567e7ea266a9f0718cf2ddafbd33ac
diff --git a/dev-python/python-magic/python-magic-0.4.18.ebuild b/dev-python/python-magic/python-magic-0.4.18.ebuild
new file mode 100644 (file)
index 0000000..681cb20
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python{2_7,3_{6..9}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Access the libmagic file type identification library"
+HOMEPAGE="https://github.com/ahupp/python-magic"
+# https://github.com/ahupp/python-magic/pull/178
+SRC_URI="https://github.com/ahupp/python-magic/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/file[-python]"
+BDEPEND="
+       test? ( sys-apps/file )
+"
+
+python_test() {
+       local -x LC_ALL=en_US.UTF-8
+       "${EPYTHON}" test/test.py -v || die "Tests fail with ${EPYTHON}"
+}