dev-lisp/clisp: Remove old.
authorUlrich Müller <ulm@gentoo.org>
Sun, 16 Jun 2019 18:30:30 +0000 (20:30 +0200)
committerUlrich Müller <ulm@gentoo.org>
Sun, 16 Jun 2019 18:30:30 +0000 (20:30 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
dev-lisp/clisp/Manifest
dev-lisp/clisp/clisp-2.48-r1.ebuild [deleted file]
dev-lisp/clisp/metadata.xml

index 3391fe4098af6e82a62db0d6887deca2dce147b7..84d215a48e0843810eeb31e880c29539f450b617 100644 (file)
@@ -1,4 +1,3 @@
-DIST clisp-2.48.tar.bz2 7885098 BLAKE2B 42ebfe4721015f522184bce710bf95d79aa7f2a239410af249a8e85d80f140344ec80daaa34f7cdbfd2ae86407984657163ce3f6e4201eb132f7c71e21523cba SHA512 3288b6a2973c924006b14bbed1e8e3e688276a187ac2a6c7851dc7ae699e7832d30e5e7eecdabc76c08c7e8e8ce1b562eb97a44570d3035e558ea2310de2b719
 DIST clisp-2.49.90.tar.bz2 8921458 BLAKE2B 3be7cfe41038f42d8844d500877fa5c20e5c21dc0e162aa0018b297e4dfcd5374ef608793c9d809852e1f9885a155bb5b25fef8efe66016dd0ee400007386b70 SHA512 1fa7205e38883dcc863160b5418ddaaa2c45ee2d2f936de4067d1ea4a1e5043bf1235361bbbfc366afd6d8f1144497ccdccf1767ecf327f7a672b18742ceb651
 DIST clisp-2.49.92.tar.bz2 9055207 BLAKE2B 6cf331eb9f99f62579e35469e2d01cae066083592ccc71cf483b70b4d1be349cdee9d403e0a7ed1ad1c8c5d805c1dab51c1a5031d77469ff8c4dc52eb58913df SHA512 cc9412a7b3f21c85b040bf5e660380fafb3c2374765a1c00272feb3f7838f2161e27a5d6295cef9976f0c4522f10796cf5ee5447716090d1cc69ecfe598ef306
 DIST clisp-2.49.tar.bz2 8091011 BLAKE2B e034c581b8100837b34d0adf1ef45bd667272d062945875175958178b4ef5b11e899dfb76505eb8cb51fca6101c11a9f21fb2cc9a78a3c0f82b06166211434f7 SHA512 eef66fc85199a2c283b616db61bf67ff103eeb0f19fa907da48994dc790b6f5f8d0c74fb3bd723c6b827c0ff3cfd89fa6ba67934fc669ed5d5249044b5140d81
diff --git a/dev-lisp/clisp/clisp-2.48-r1.ebuild b/dev-lisp/clisp/clisp-2.48-r1.ebuild
deleted file mode 100644 (file)
index dbdf14a..0000000
+++ /dev/null
@@ -1,164 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="2"
-
-inherit flag-o-matic eutils toolchain-funcs multilib xdg-utils
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="https://clisp.sourceforge.io/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 ia64 ppc -sparc x86"
-IUSE="berkdb hyperspec X new-clx dbus fastcgi gdbm gtk +pcre postgres +readline svm -threads +unicode +zlib"
-
-RDEPEND="virtual/libiconv
-                >=dev-libs/libsigsegv-2.4
-                >=dev-libs/ffcall-1.10
-                dbus? ( sys-apps/dbus )
-                fastcgi? ( dev-libs/fcgi )
-                gdbm? ( sys-libs/gdbm )
-                gtk? ( >=x11-libs/gtk+-2.10:2 >=gnome-base/libglade-2.6:2.0 )
-                postgres? ( >=dev-db/postgresql-8.0 )
-                readline? ( >=sys-libs/readline-5.0 )
-                pcre? ( dev-libs/libpcre )
-                svm? ( sci-libs/libsvm )
-                zlib? ( sys-libs/zlib )
-                X? ( new-clx? ( x11-libs/libXpm ) )
-                hyperspec? ( dev-lisp/hyperspec )
-                berkdb? ( sys-libs/db:4.5 )"
-
-DEPEND="${RDEPEND}
-       X? ( new-clx? ( x11-base/xorg-proto x11-misc/imake ) )"
-
-# dev-lisp/gentoo-init is obsolete, it will be dropped soon
-# This version of clisp is its last consumer
-# Bug 648448
-#PDEPEND="dev-lisp/gentoo-init"
-
-enable_modules() {
-       [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
-       for m in "$@" ; do
-               einfo "enabling module $m"
-               myconf+=" --with-module=${m}"
-       done
-}
-
-BUILDDIR="builddir"
-
-# modules not enabled:
-#  * berkdb: must figure out a way to make the configure script pick up the
-#            currect version of the library and headers
-#  * dirkey: fails to compile, requiring windows.h, possibly wrong #ifdefs
-#  * matlab, netica: not in portage
-#  * oracle: can't install oracle-instantclient
-
-src_prepare() {
-       # More than -O1 breaks alpha/ia64
-       if use alpha || use ia64; then
-               sed -i -e 's/-O2//g' src/makemake.in || die
-       fi
-       xdg_environment_reset
-}
-
-src_configure() {
-       # We need this to build on alpha/ia64
-       if use alpha || use ia64; then
-               replace-flags -O? -O1
-               append-flags '-D NO_MULTIMAP_SHM -D NO_MULTIMAP_FILE -D NO_SINGLEMAP -D NO_TRIVIALMAP'
-       fi
-
-       # QA issue with lisp.run
-       append-flags -Wa,--noexecstack
-
-       # built-in features
-       local myconf="--with-ffcall --without-dynamic-modules"
-#    There's a problem with jit_allocai function
-#    if use jit; then
-#        myconf+=" --with-jitc=lightning"
-#    fi
-       if use threads; then
-               myconf+=" --with-threads=POSIX_THREADS"
-       fi
-
-       # default modules
-       enable_modules wildcard rawsock
-       # optional modules
-       use elibc_glibc && enable_modules bindings/glibc
-       if use X; then
-               if use new-clx; then
-                       enable_modules clx/new-clx
-               else
-                       enable_modules clx/mit-clx
-               fi
-       fi
-       if use postgres; then
-               enable_modules postgresql
-               append-flags -I$(pg_config --includedir)
-       fi
-       if use berkdb; then
-               enable_modules berkeley-db
-               append-flags -I/usr/include/db4.5
-       fi
-       use dbus && enable_modules dbus
-       use fastcgi && enable_modules fastcgi
-       use gdbm && enable_modules gdbm
-       use gtk && enable_modules gtk2
-       use pcre && enable_modules pcre
-       use svm && enable_modules libsvm
-       use zlib && enable_modules zlib
-
-       if use hyperspec; then
-               CLHSROOT="file:///usr/share/doc/hyperspec/HyperSpec/"
-       else
-               CLHSROOT="http://www.lispworks.com/reference/HyperSpec/"
-       fi
-
-       # configure chokes on --sysconfdir option
-       local configure="./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
-               $(use_with readline) $(use_with unicode) \
-               ${myconf} --hyperspec=${CLHSROOT} ${BUILDDIR}"
-       einfo "${configure}"
-       ${configure} || die "./configure failed"
-
-       sed -i 's,"vi","nano",g' "${BUILDDIR}"/config.lisp || die
-
-       IMPNOTES="file://${ROOT%/}/usr/share/doc/${PN}-${PVR}/html/impnotes.html"
-       sed -i "s,http://clisp.cons.org/impnotes/,${IMPNOTES},g" \
-               "${BUILDDIR}"/config.lisp || die
-}
-
-src_compile() {
-       export VARTEXFONTS="${T}"/fonts
-       cd "${BUILDDIR}"
-       # parallel build fails
-       emake -j1 || die "emake failed"
-}
-
-src_install() {
-       pushd "${BUILDDIR}"
-       make DESTDIR="${D}" prefix=/usr install-bin || die
-       doman clisp.1 || die
-       dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE || die
-       fperms a+x /usr/$(get_libdir)/clisp-${PV/_*/}/clisp-link || die
-       popd
-       dohtml doc/impnotes.{css,html} doc/regexp.html doc/clisp.png || die
-       dodoc doc/{CLOS-guide,LISP-tutorial}.txt || die
-}
-
-pkg_postinst() {
-       if use threads || use jit; then
-               while read line; do elog ${line}; done <<EOF
-
-Upstream considers threads to be of Alpha quality, therefore
-it is likely that you will encounter bugs in using them. If you do,
-please report bugs upstream:
-
-Mailing list: https://sourceforge.net/projects/clisp/lists/clisp-devel
-Bug tracker:  https://sourceforge.net/p/clisp/bugs/
-
-EOF
-       fi
-}
index cb525b83d17279eb54e668b870e2012ce1d90311..88ea109143fa9db1b915eb78aea5ed42f8bb3c2b 100644 (file)
@@ -20,8 +20,6 @@ changed at run time.
 </longdescription>
        <use>
                <flag name="hyperspec">Use local hyperspec instead of online version</flag>
-               <flag name="new-clx">Build CLISP with support for the NEW-CLX module which is a
--C binding to the Xorg libraries</flag>
                <flag name="svm">Build CLISP with support for the Support Vector Machine module</flag>
        </use>
        <upstream>