app-emulation/ski: tweak for binutils-2.34
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 1 Feb 2020 22:52:11 +0000 (22:52 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 1 Feb 2020 22:52:51 +0000 (22:52 +0000)
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
app-emulation/ski/files/ski-1.3.2-binutils-2.34.patch [new file with mode: 0644]
app-emulation/ski/ski-1.3.2-r3.ebuild

diff --git a/app-emulation/ski/files/ski-1.3.2-binutils-2.34.patch b/app-emulation/ski/files/ski-1.3.2-binutils-2.34.patch
new file mode 100644 (file)
index 0000000..dcb3f67
--- /dev/null
@@ -0,0 +1,22 @@
+diff --git a/src/linux/dwarf-linux.c b/src/linux/dwarf-linux.c
+index 73be0e6..c4051a3 100644
+--- a/src/linux/dwarf-linux.c
++++ b/src/linux/dwarf-linux.c
+@@ -116,14 +116,14 @@ find_in_section (bfd * bfd, asection * sect, PTR obj)
+   /*
+    * we're looking at loadable code only
+    */
+-  if ((bfd_get_section_flags (bfd, sect) & (SEC_CODE | SEC_ALLOC)) == 0)
++  if ((bfd_section_flags (sect) & (SEC_CODE | SEC_ALLOC)) == 0)
+     return;
+   /*
+    * check if address belongs to this section
+    */
+-  vma = bfd_get_section_vma (bfd, sect);
+-  size = bfd_section_size (bfd, sect);
++  vma = bfd_section_vma (sect);
++  size = bfd_section_size (sect);
+   offset = info->address - vma;
+   if (offset >= size)
index e64df45c1250d80207aa5bfc421cacaa42c49703..7fa7d9227e066a201c498755e3964bc0dadb3220 100644 (file)
@@ -44,6 +44,10 @@ PATCHES=(
 src_prepare() {
        default
 
+       if has_version ">=sys-libs/binutils-libs-2.34"; then
+               eapply "${FILESDIR}"/${PN}-1.3.2-binutils-2.34.patch
+       fi
+
        rm -rf libltdl src/ltdl.[ch] macros/ltdl.m4
 
        AT_M4DIR="macros" eautoreconf