dev-ml/ocaml-ipaddr: update to opam.eclass
authorAlexis Ballier <aballier@gentoo.org>
Fri, 22 Sep 2017 08:25:57 +0000 (10:25 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 22 Sep 2017 08:31:45 +0000 (10:31 +0200)
Package-Manager: Portage-2.3.10, Repoman-2.3.3

dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.8.0.ebuild

index 963f7245bbd596c22ecac4e6c7d530a4dd696ba9..c4a103f9a450ba7db0c7bb41bc8f836be56515f7 100644 (file)
@@ -3,6 +3,8 @@
 
 EAPI=5
 
+inherit opam
+
 DESCRIPTION="OCaml library for manipulation of IP (and MAC) address representations"
 HOMEPAGE="https://github.com/mirage/ocaml-ipaddr"
 SRC_URI="https://github.com/mirage/ocaml-ipaddr/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -20,16 +22,10 @@ RDEPEND="dev-ml/sexplib:=
 "
 DEPEND="${RDEPEND}
        dev-ml/jbuilder
-       dev-ml/opam
        dev-ml/findlib
        test? ( dev-ml/ounit )
 "
 
 src_install() {
-       opam-installer -i \
-               --prefix="${ED}/usr" \
-               --libdir="${D}/$(ocamlc -where)" \
-               --docdir="${ED}/usr/share/doc/${PF}" \
-               ipaddr.install || die
-       dodoc CHANGES.md README.md
+       opam_src_install ipaddr
 }