games-util/springlobby: 0.269 version bump
authorOursDesCavernes <totocoq@yahoo.fr>
Tue, 17 Mar 2020 20:34:48 +0000 (21:34 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 25 Mar 2020 13:45:22 +0000 (15:45 +0200)
Signed-off-by: Thomas Coquelin <totocoq@yahoo.fr>
Closes: https://bugs.gentoo.org/708400
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Closes: https://github.com/gentoo/gentoo/pull/14997
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
games-util/springlobby/Manifest
games-util/springlobby/springlobby-0.269.ebuild [new file with mode: 0644]

index 87dde623bbe7b4860f955647fdb05f17004f5138..fa4c8245e85a03c8f0d91d1a69a532a0e619980f 100644 (file)
@@ -1,2 +1,3 @@
 DIST springlobby-0.266.tar.bz2 2642384 BLAKE2B 93444df4e139a657dc5d87b0ea9e796bd025259663693de9dcb04760ee611674546170813d71406e94aa456834cc96c8bc811ee5cf65b0bd0199cf66b4a51a50 SHA512 dc1a5e408515cb82004bf66bc014ebdd451eaea07d3543094cec494beb6d87165bdc0ac3672d6474a13d1918b1405507ee97ead05b9f1663789416b072aa6d6b
 DIST springlobby-0.267.tar.bz2 2642229 BLAKE2B 591eddda344ea4ce4ed7cad433bd7d46c7b2e727d7f97c07541cc00c6991fb1a9a62e8980f6a0249e6a509e475fe300aeb040ff1886f2da77b176b52d196db90 SHA512 6127bd7377f9a843b23df6dae7a07af1122f6ec5fa13cd8d16c0c7a3cc84e1f7af2fb7df929f904ee0b4e3abf12ae1e525ffb39b2afa0215433209054cf0de5f
+DIST springlobby-0.269.tar.bz2 4576001 BLAKE2B bd55b480c98d74bc83f99bf32148ef2be5e1f59e1539fdb432430d5e36e653e1c3d550bc7a3c996e5df029a19ea729d456f34ae3522a2a6385a0d646697e537c SHA512 32e9b5bfc72bcfccd1487621e6035e7338977f7262702cd39ec2c43734bff5b8757a97428d1207f8e6721dd450c1cddd68e43cea416503dd1987596e61e126e1
diff --git a/games-util/springlobby/springlobby-0.269.ebuild b/games-util/springlobby/springlobby-0.269.ebuild
new file mode 100644 (file)
index 0000000..e8b393a
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0"
+inherit cmake xdg-utils wxwidgets
+
+DESCRIPTION="The official lobby client for SpringRTS community games"
+HOMEPAGE="https://springlobby.springrts.com"
+SRC_URI="https://springlobby.springrts.com/dl/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +libnotify +nls +sound"
+
+RDEPEND="
+       dev-libs/openssl:0=
+       net-misc/curl
+       sys-libs/zlib[minizip]
+       x11-libs/libICE
+       x11-libs/libSM
+       x11-libs/libXext
+       x11-libs/wxGTK:${WX_GTK_VER}[X]
+       libnotify? ( x11-libs/libnotify )
+       sound? (
+               media-libs/alure
+               media-libs/openal
+       )
+"
+
+BDEPEND="${RDEPEND}
+       nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+       setup-wxwidgets
+       local mycmakeargs=(
+               -DOPTION_NOTIFY=$(usex libnotify)
+               -DOPTION_SOUND=$(usex sound)
+               -DOPTION_TRANSLATION_SUPPORT=$(usex nls)
+               -DAUX_VERSION="(Gentoo,${ARCH})"
+               )
+       cmake_src_configure
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}