dev-python/pyblake2: New package
authorMichał Górny <mgorny@gentoo.org>
Fri, 20 Oct 2017 23:13:50 +0000 (01:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 20 Oct 2017 23:44:07 +0000 (01:44 +0200)
Add a package providing Python extension with BLAKE2, for use
as a fallback hash provider in sys-apps/portage.

dev-python/pyblake2/Manifest [new file with mode: 0644]
dev-python/pyblake2/metadata.xml [new file with mode: 0644]
dev-python/pyblake2/pyblake2-0.9.3.ebuild [new file with mode: 0644]

diff --git a/dev-python/pyblake2/Manifest b/dev-python/pyblake2/Manifest
new file mode 100644 (file)
index 0000000..3dd6e51
--- /dev/null
@@ -0,0 +1 @@
+DIST pyblake2-0.9.3.tar.gz 130641 SHA256 626448e1fe1cc01d2197118954bec9f158378577e12686d5b01979f7f0fa2212 SHA512 6336a7f7e79bd3e6ff7f8ff4d279ae170e86f1464b9fa9e7ea7f0dbbac6fcc044caf225111e065f9cd9cdeea0f81fae8d373e1f65be3e418929f53fad063205e WHIRLPOOL 0d8f2aaf35a5eb0ebdedd9219a0ee8b126c93b11ae3e406ef637d8930a34783886b212ce50a33d677b0a19289cd32f40dc3da22a9a9fec108b481268f153d45b
diff --git a/dev-python/pyblake2/metadata.xml b/dev-python/pyblake2/metadata.xml
new file mode 100644 (file)
index 0000000..98aa90f
--- /dev/null
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>mgorny@gentoo.org</email>
+               <name>Michał Górny</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">dchest/pyblake2</remote-id>
+               <remote-id type="pypi">pyblake2</remote-id>
+       </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyblake2/pyblake2-0.9.3.ebuild b/dev-python/pyblake2/pyblake2-0.9.3.ebuild
new file mode 100644 (file)
index 0000000..37d5457
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+inherit distutils-r1
+
+DESCRIPTION="BLAKE2 hash function extension module"
+HOMEPAGE="https://github.com/dchest/pyblake2 https://pypi.python.org/pypi/pyblake2"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_test() {
+       "${EPYTHON}" test/test.py || die "Tests fail with ${EPYTHON}"
+}