games-engines/openmw: version bump to 0.44.0.
authorktrace <coyote@bks.tv>
Sat, 11 Aug 2018 17:10:25 +0000 (20:10 +0300)
committerPatrice Clement <monsieurp@gentoo.org>
Tue, 21 Aug 2018 08:28:57 +0000 (10:28 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Closes: https://github.com/gentoo/gentoo/pull/9540

games-engines/openmw/Manifest
games-engines/openmw/openmw-0.44.0.ebuild [new file with mode: 0644]

index f8613631338b3ae3586f06a87a2313dc66c4bf57..6db67c29ed04af5707513d7eab3348c3e00d5639 100644 (file)
@@ -1 +1,2 @@
 DIST openmw-0.43.0.tar.gz 5023421 BLAKE2B c99e3a23b22b642dea9e8f2d9414e00aa6a05c4331a9715882465781caca60cd857675d87079bafc3596783e257213bec9d6f1f4e78a3d795e973fb1d895811e SHA512 e902dd2274c05838bb1171f07d7a673fc7b85d1290a9e01c8ab89f1c279bd236332ecdc0f2b7944ec7209a0e6022ff472639b5724bf26904e3a2d338c7be401a
+DIST openmw-0.44.0.tar.gz 4976422 BLAKE2B 9dec8412aa68ac35ba51926c7e5c5a64ce717ea6677162e0b35439a59c482375b7729bd462fa6e8da2e9b463c1121cdca0a5b42f553095da82a83cefb11986ce SHA512 1b178891274361b7821ac1d3d66976ed5d443545531499d98f7ed30823f3891172cc5dcb3f7382ba0f561774a92b9ad8805e0c9582b78d2f010e4ed661219017
diff --git a/games-engines/openmw/openmw-0.44.0.ebuild b/games-engines/openmw/openmw-0.44.0.ebuild
new file mode 100644 (file)
index 0000000..fa31e8d
--- /dev/null
@@ -0,0 +1,125 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils readme.gentoo-r1
+
+DESCRIPTION="Open source reimplementation of TES III: Morrowind"
+HOMEPAGE="https://openmw.org/"
+SRC_URI="https://github.com/OpenMW/openmw/archive/${P}.tar.gz"
+
+LICENSE="GPL-3 MIT BitstreamVera ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc devtools +qt5"
+
+RDEPEND="
+       dev-games/mygui
+       >=dev-games/openscenegraph-3.5.5[ffmpeg,jpeg,png,sdl,svg,truetype,zlib]
+       dev-games/openscenegraph-qt
+       dev-libs/boost:=[threads]
+       dev-libs/tinyxml[stl]
+       media-libs/libsdl2[joystick,opengl,video,X]
+       media-libs/openal
+       media-video/ffmpeg:=
+       >=sci-physics/bullet-2.86
+       virtual/opengl
+       qt5? (
+               app-arch/unshield
+               dev-qt/qtcore:5
+               dev-qt/qtnetwork:5
+               dev-qt/qtopengl:5
+               dev-qt/qtwidgets:5
+       )
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       doc? ( app-doc/doxygen[doc] dev-python/sphinx )"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+       cmake-utils_src_prepare
+
+       # We don't install license files
+       sed -e '/LICDIR/d' \
+               -i CMakeLists.txt || die
+       # Use the system tinyxml headers
+       sed -e 's/"tinyxml.h"/<tinyxml.h>/g' \
+               -e 's/"tinystr.h"/<tinystr.h>/g' \
+               -i extern/oics/ICSPrerequisites.h || die
+}
+
+src_configure() {
+       use devtools && ! use qt5 && \
+               elog "'qt5' USE flag is disabled, 'openmw-cs' will not be installed"
+
+       local mycmakeargs=(
+               -DBUILD_BSATOOL=$(usex devtools)
+               -DBUILD_DOCS=$(usex doc)
+               -DBUILD_ESMTOOL=$(usex devtools)
+               -DBUILD_LAUNCHER=$(usex qt5)
+               -DBUILD_NIFTEST=$(usex devtools)
+               -DBUILD_OPENCS=$(usex devtools $(usex qt5))
+               -DBUILD_WIZARD=$(usex qt5)
+               -DBUILD_UNITTESTS=OFF
+               -DGLOBAL_DATA_PATH=/usr/share
+               -DICONDIR="/usr/share/icons/hicolor/256x256/apps"
+               -DMORROWIND_DATA_FILES="/usr/share/morrowind-data"
+               -DUSE_SYSTEM_TINYXML=ON
+               -DDESIRED_QT_VERSION=5
+       )
+
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cmake-utils_src_compile
+
+       if use doc ; then
+               cmake-utils_src_compile doc
+               find "${CMAKE_BUILD_DIR}"/docs/Doxygen/html \
+                       -name '*.md5' -type f -delete || die
+               HTML_DOCS=( "${CMAKE_BUILD_DIR}"/docs/Doxygen/html/. )
+       fi
+}
+
+src_install() {
+       cmake-utils_src_install
+
+       local DOC_CONTENTS="
+       You need the original Morrowind data files. If you haven't
+       installed them yet, you can install them straight via the
+       installation wizard which is the officially supported method
+       (either by using the launcher or by calling 'openmw-wizard'
+       directly).\n"
+
+       if ! use qt5; then
+               local DOC_CONTENTS+="\n\n
+               USE flag 'qt5' is disabled, 'openmw-launcher' and
+               'openmw-wizard' are not available. You are on your own for
+               making the Morrowind data files available and pointing
+               openmw at them.\n\n
+               Additionally; you must import the Morrowind.ini file before
+               running openmw with the Morrowind data files for the first
+               time. Typically this can be done like so:\n\n
+               \t mkdir -p ~/.config/openmw\n
+               \t openmw-iniimporter /path/to/Morrowind.ini ~/.config/openmw/openmw.cfg"
+       fi
+
+       readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+       readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}