dev-python/pyudev: Remove old
authorDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:52:33 +0000 (09:52 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 29 Dec 2019 08:52:33 +0000 (09:52 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/pyudev/Manifest
dev-python/pyudev/pyudev-0.20.0-r1.ebuild [deleted file]

index 0aced863fe363527d03dddc294716949c3df4786..5b73a2d2813e912076ede7c2afd7245b1c42d901 100644 (file)
@@ -1,2 +1 @@
-DIST pyudev-0.20.0.tar.gz 93217 BLAKE2B 9426b3f012be0b1bcacb7f3ed8b33d7965a2a8d7c676f032a0f2f9e6013f52090ddf82434ba01411cc2886796d34f736dc3d2e1abd6f45ee7ad516e9d5f45f90 SHA512 e86a776a2b6d29f206cdd0057c6f9b1e705d981ec8c2de49259887647856531af68238b80751102a3ffc8cea6f234cc520d62c8bc2da686e453ed010da3ebb02
 DIST pyudev-0.21.0.tar.gz 89469 BLAKE2B 3bf9ac46442c5948d131932c7b62a59ef979755f2d55bcd0165fc1b69b865268051fdeab7605c8a1cb0694ce0f4b88f31a1e6a1893900a7300ddf6439734712e SHA512 ba5b6156768b65b9655d809b14378b01173643781b9c4017271e880cdfed442c44ac49eb26c970e4275b820e01678e3001870591fccf88dc713ec941e2b85d11
diff --git a/dev-python/pyudev/pyudev-0.20.0-r1.ebuild b/dev-python/pyudev/pyudev-0.20.0-r1.ebuild
deleted file mode 100644 (file)
index 7c77d83..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python binding to libudev"
-HOMEPAGE="https://pyudev.readthedocs.io/en/latest/ https://github.com/pyudev/pyudev"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 x86"
-IUSE="pygobject test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-python/six[${PYTHON_USEDEP}]
-       virtual/udev
-       pygobject? ( dev-python/pygobject:2[$(python_gen_usedep 'python2*')] )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/docutils[${PYTHON_USEDEP}]
-               dev-python/hypothesis[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
-       )"
-
-DOCS=( CHANGES.rst README.rst )
-
-PATCHES=(
-       "${FILESDIR}/${PN}-0.19.0-skip-non-deterministic-test.patch"
-)
-
-REQUIRED_USE="pygobject? ( || ( $(python_gen_useflags 'python2*') ) )"
-
-python_prepare_all() {
-       if use test; then
-               ewarn "If your PORTAGE_TMPDIR is longer in length then '/var/tmp/',"
-               ewarn "change it to /var/tmp to ensure tests will pass."
-       fi
-
-       # tests are known to pass then fail on alternate runs
-       # tests: fix run_path
-       sed -i -e "s|== \('/run/udev'\)|in (\1,'/dev/.udev')|g" \
-               tests/test_core.py || die
-
-       # test needs needs newer dev-cpp/gccxml
-       rm -f tests/test_libudev.py
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       py.test || die "Tests fail with ${EPYTHON}"
-}