x11-plugins/enigmail: Synced live ebuild
authorLars Wendler <polynomial-c@gentoo.org>
Tue, 16 Jul 2019 10:12:20 +0000 (12:12 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Tue, 16 Jul 2019 10:13:14 +0000 (12:13 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
x11-plugins/enigmail/enigmail-9999.ebuild

index 752b1acb8637631006f98d1ff8cf90f626413617..d2c798ea50305203329b191c2c532f3036be3dce 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -44,14 +44,19 @@ DEPEND="${RDEPEND}
        dev-lang/perl
        "
 
+PATCHES=( "${FILESDIR}"/enigmail-no_pEp_auto_download.patch )
+
 src_compile() {
+       # Required or parallel make fails
+       emake -C stdlib createlib
+
        emake ipc public ui package lang stdlib
        emake xpi
 
 }
 
 src_install() {
-       local emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' build/dist/install.rdf)
+       local emid=$(sed -n '/"id":/!d; s/.*\({.*}\).*/\1/; p; q' build/dist/manifest.json)
        [[ -n ${emid} ]] || die "Could not scrape EM:ID from install.rdf"
 
        mv build/enigmail*.xpi build/"${emid}.xpi" || die 'Could not rename XPI to match EM:ID'