Don't depend on virtual/alsa (those are drivers), depend properly on media-libs/alsa...
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Sun, 11 Feb 2007 18:13:43 +0000 (18:13 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Sun, 11 Feb 2007 18:13:43 +0000 (18:13 +0000)
Package-Manager: portage-2.1.2-r9

media-sound/radiomixer/ChangeLog
media-sound/radiomixer/radiomixer-1.0.ebuild
media-sound/specimen/ChangeLog
media-sound/specimen/specimen-0.4.5.ebuild

index 2684dda749c53767eb3e5b635eb82dd423093e56..def878c4e261ab4160ea6732ae3061a5a4d6a989 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for media-sound/radiomixer
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/radiomixer/ChangeLog,v 1.4 2006/05/18 12:00:35 jokey Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/radiomixer/ChangeLog,v 1.5 2007/02/11 18:11:50 flameeyes Exp $
+
+  11 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> radiomixer-1.0.ebuild:
+  Don't depend on virtual/alsa (those are drivers), depend properly on
+  media-libs/alsa-lib.
 
   18 May 2006; Markus Ullmann <jokey@gentoo.org> radiomixer-1.0.ebuild:
   Removing the qmake call as it is done by upstreams configure now
index 7fed39fd0d3ff58bfe8267f253fb4ed6d23c0d78..244ed6fff24f6199d0035c6fddfbb8d242ae5ccb 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/radiomixer/radiomixer-1.0.ebuild,v 1.2 2006/05/18 12:00:35 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/radiomixer/radiomixer-1.0.ebuild,v 1.3 2007/02/11 18:11:50 flameeyes Exp $
 
 inherit kde-functions eutils
 
@@ -14,7 +14,7 @@ KEYWORDS="~amd64 ~x86"
 IUSE="alsa debug hwmixer jack mad songdb vorbis"
 
 DEPEND="media-libs/libsamplerate
-       alsa? ( virtual/alsa )
+       alsa? ( media-libs/alsa-lib )
        jack? ( media-sound/jack-audio-connection-kit )
        mad? ( media-libs/libmad )
        vorbis? ( media-libs/libvorbis )"
@@ -64,22 +64,22 @@ src_compile() {
 
        local myconf
        if ! use alsa ; then
-           myconf="--disable-alsa"
+               myconf="--disable-alsa"
        fi
        if use hwmixer ; then
-           myconf="${myconf} --enable-hwmixer"
+               myconf="${myconf} --enable-hwmixer"
        fi
        if ! use jack ; then
-           myconf="${myconf} --disable-jackd"
+               myconf="${myconf} --disable-jackd"
        fi
        if ! use mad ; then
-           myconf="${myconf} --disable-mad"
+               myconf="${myconf} --disable-mad"
        fi
        if use songdb ; then
-           myconf="${myconf} --enable-songdb"
+               myconf="${myconf} --enable-songdb"
        fi
        if ! use vorbis ; then
-           myconf="${myconf} --disable-vorbis"
+               myconf="${myconf} --disable-vorbis"
        fi
        if use debug ; then
                myconf="${myconf} --debug"
index db342e86a6f5a71d37938cff9f514e701da569fb..006907aa6ec02eadc01b8cbf5da8e72aaa0aaf9f 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for media-sound/specimen
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/specimen/ChangeLog,v 1.12 2006/09/13 18:21:45 tove Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/specimen/ChangeLog,v 1.13 2007/02/11 18:13:43 flameeyes Exp $
+
+  11 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> specimen-0.4.5.ebuild:
+  Don't depend on virtual/alsa (those are drivers), depend properly on
+  media-libs/alsa-lib.
 
 *specimen-0.5.1 (06 Aug 2006)
 
index c22878d732201d8b20f101cfc371820f8699a68e..6247b6b2feefb9f35f53683fad1b44f02b78bd2d 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/specimen/specimen-0.4.5.ebuild,v 1.5 2005/06/12 12:14:14 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/specimen/specimen-0.4.5.ebuild,v 1.6 2007/02/11 18:13:43 flameeyes Exp $
 
 DESCRIPTION="A Midi Controllable Audio Sampler"
 HOMEPAGE="http://www.gazuga.net"
@@ -13,7 +13,7 @@ KEYWORDS="-amd64 ~ppc sparc x86"
 IUSE="ladcca debug"
 
 DEPEND="media-sound/jack-audio-connection-kit
-       virtual/alsa
+       media-libs/alsa-lib
        media-libs/libsamplerate
        media-libs/libsndfile
        media-libs/phat