dev-ml/ocaml-ctypes: bump to 0.4.2
authorAlexis Ballier <aballier@gentoo.org>
Mon, 22 Feb 2016 10:22:39 +0000 (11:22 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 22 Feb 2016 10:22:47 +0000 (11:22 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ml/ocaml-ctypes/Manifest
dev-ml/ocaml-ctypes/ocaml-ctypes-0.4.2.ebuild [new file with mode: 0644]

index 88844f37a9482b5a691688993a71a87571674293..79985b88ff760265e04841a8b121e24c5680edb9 100644 (file)
@@ -1 +1,2 @@
 DIST ocaml-ctypes-0.4.1.tar.gz 162601 SHA256 74564e049de5d3c0e76ea284c225cb658ac1a2b483345be1efb9be4b3c1702f5 SHA512 8155ffe16a58d5714ceb602afa5531c93526defca39a16047328ac06d2c7c7f52b768b18170391f467e1f6919c69275734faf85d27315e11b8bbefcb1bc8afa9 WHIRLPOOL d8d0ef24e0b6c40f50fddf38fed7238cf95573909d2809cc2ab5c1b9b3dab333210e1ce99cf805804576a79d08d819e2ecdee7b4a6a9e13efb13e7b9f88ad802
+DIST ocaml-ctypes-0.4.2.tar.gz 162968 SHA256 704efcbf3b99c180855ad4faed0dd7cec4f2384f9b8963b572329697be8cbae4 SHA512 78e51a4ea35efd6d854b81c65d3e224175927a3c87b9b665d173cefeb3f424e1ed8fc8dfbbb4ce33b4bc43163ecf647ba9b502e69c82eb05ddcde66b8d6c99e4 WHIRLPOOL 124c6f91ae1ae980994f8cca483a2090c60b62864abe8d4b9aac725b2131f331d385a6a1e5b7685e4f61ac4e3e53cb22ac0cad9b32ebefa444d2ef00e15f7caa
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.4.2.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.4.2.ebuild
new file mode 100644 (file)
index 0000000..8ebc7be
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+       >=dev-lang/ocaml-4.02:=[ocamlopt]
+       virtual/libffi
+"
+DEPEND="${RDEPEND}
+       test? ( dev-ml/ounit )"
+
+src_compile() {
+       emake -j1
+}
+
+src_test() {
+       emake -j1 test
+}
+
+src_install() {
+       findlib_src_install
+       dodoc CHANGES.md README.md
+}