dev-util/pycharm-community: Version bump (2019.1.2)
authorMikle Kolyada <zlogene@gentoo.org>
Wed, 8 May 2019 10:20:32 +0000 (13:20 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Wed, 8 May 2019 10:20:32 +0000 (13:20 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-util/pycharm-community/Manifest
dev-util/pycharm-community/pycharm-community-2019.1.2.ebuild [new file with mode: 0644]

index de8aa9cf7b32a2569308dce0ea819f0eb161194f..87ab0774686d50826620bd079030b113c7e45734 100644 (file)
@@ -1,4 +1,5 @@
 DIST pycharm-community-2018.3.4.tar.gz 310736836 BLAKE2B 2d43955b4d4299026c3fccd00c42e71b98c314d33857b1f81a84f365efde4b89d29b8c20826a3f89b6dc36fb293d867874edc75d68f5070516a27ccb68034cd2 SHA512 35b133b0db3b7fdbc4f08d0070de5aec8b3f170657c932e5c5c0af2e8c4be8b9e408558a0595794acd73e2ef5085295929b2a11013e6e72b852fead4ce572f60
 DIST pycharm-community-2018.3.5.tar.gz 311914955 BLAKE2B d4e1e2cc19a416d7f5ecc1ee181c0b6a4e29ee3577800f2426ec84a7a16f53992526b1df8e3ccd43ccbdeeb7f6521d579fad41d145ecfd24408d2d18b9b577d6 SHA512 a81c95397388b243a5b548e2b4bc54f1be3fdedd191c33a90f57a53002d90eb462d5fbc69b2fa88ccb35d8521cd1224e4491928e4c1810a2e7429a6ba6050d36
 DIST pycharm-community-2019.1.1.tar.gz 332489780 BLAKE2B 2cc7dcbab5fa321e423991622b4e7c9e41c184312a4b3c3a8b900b1ea2436d9f6009e26ffca12f3335be8bb520941c6ac6b579f3e6f2fc0f1b148a9a00ab1868 SHA512 28d7a3353bec271f0a57bea3c44fc788a5b3a5215dff737ba293c2ce73509d06b217ee1615901c91e5895d61a58a2b696c50ae760b6b3a88b472f3746f28bcbf
+DIST pycharm-community-2019.1.2.tar.gz 333983594 BLAKE2B f5dfa1986d88c7598cfbd5050c385a1b1b3374286e57fd513a94eb19bc42116b1ceef757d194ef1df66739b25f10663a74e374785b4c5584aec9b8900e67dd0c SHA512 48782960022efe48f37b2bdec0be1f15741f6dde2a2dcec686ecfb07c81996c3d6fc46cf3eda2fa4cc53a67f7ec47909e47ed57b2edbf973482ca37781067415
 DIST pycharm-community-2019.1.tar.gz 330592651 BLAKE2B 4165a1bd9cd63e70b9f982bca4324b2aa1db32bc73bf30e521ed5921eb4b03ffe98004d16600c1795cc974d5188c24a17c988c6b37a90a5d038b0492a692275a SHA512 aa411f7354c7954d22e51246349b66a13cf0544a00ee92945ceb072f3636a020b0ee812a84d49c74e2121561af4f96e9fb6f7b26f69bc473c15ed15614fd16ab
diff --git a/dev-util/pycharm-community/pycharm-community-2019.1.2.ebuild b/dev-util/pycharm-community/pycharm-community-2019.1.2.ebuild
new file mode 100644 (file)
index 0000000..3bd1b2c
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils readme.gentoo-r1 xdg
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.8
+       dev-libs/libdbusmenu
+       dev-python/pip"
+
+RESTRICT="mirror strip"
+
+QA_PREBUILT="opt/${PN}/bin/fsnotifier
+       opt/${PN}/bin/fsnotifier64
+       opt/${PN}/bin/fsnotifier-arm"
+
+MY_PN=${PN/-community/}
+
+src_prepare() {
+       default
+
+       rm -rf jre || die
+}
+
+src_install() {
+       insinto /opt/${PN}
+       doins -r *
+
+       fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+       dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+       newicon bin/${MY_PN}.png ${PN}.png
+       make_desktop_entry ${PN} ${PN} ${PN}
+
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_pkg_postrm
+       gnome2_icon_cache_update
+}