dev-python/flask-socketio: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 09:10:16 +0000 (10:10 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 09:16:17 +0000 (10:16 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/flask-socketio/Manifest
dev-python/flask-socketio/flask-socketio-2.9.2.ebuild [deleted file]

index 2a2654a179a882901d957991d6b754fb5ec20b4a..0437a982beb46e42aa07f3a839c86ca46e41d29b 100644 (file)
@@ -1,2 +1 @@
-DIST flask-socketio-2.9.2.tar.gz 14361 BLAKE2B 0db8ddee5fe8c7dda384a22d2880a7ebf8d25b6ee76d257012823fbe4388bcfebe01a362521fb5e5abfeca72b7b3ca2a53493081e5d42f6443d410871b6fb53e SHA512 6fc499a32f37752e6d6d62fc52787cca795f3d113315402bab8063f7b7041785a7c90aff1bd393ef12ba84f2547607920b5f3146271dc536847c07ef0ffb0617
 DIST flask-socketio-3.0.1.tar.gz 14698 BLAKE2B 5d00cee05c2549714093a3fa680433e4262d14f73f268919efaf7c2345a393f84b8d735e5ea9da911a2e011c581e9eb5a2e4914bbdd8a4721b1ef81a071cbdd4 SHA512 3097f98e479bf1f24676dbecf9e151096f1ea59604396feb2d3e0509551b5b41ce3ac0926660bfdf7e113007633f6b02edb81c9c8656e06fe2f2a02a3e419772
diff --git a/dev-python/flask-socketio/flask-socketio-2.9.2.ebuild b/dev-python/flask-socketio/flask-socketio-2.9.2.ebuild
deleted file mode 100644 (file)
index 37f29e7..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 pypy3 )
-
-inherit distutils-r1
-
-MY_PN="Flask-SocketIO"
-DESCRIPTION="Socket.IO integration for Flask applications."
-HOMEPAGE="https://flask-socketio.readthedocs.org/ https://github.com/miguelgrinberg/Flask-SocketIO/ https://pypi.org/project/Flask-SocketIO/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=">=dev-python/flask-0.9[${PYTHON_USEDEP}]
-       >=dev-python/python-socketio-1.5.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/coverage[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-# pypi tarball does not contain tests
-RESTRICT="test"
-
-python_test() {
-       PYTHONPATH="${PWD}" python ./test_socketio.py || die
-}